MBP/BootCamp/win7 usb drives 'not recognised'

Discussion in 'Windows, Linux & Others on the Mac' started by andrewdroid, Oct 12, 2014.

  1. andrewdroid macrumors newbie

    Joined:
    Sep 25, 2014
    #1
    Hi all
    OK i'm new to Mac (as of March 2014) as always been a windows/Linux user.
    I'm running a MBP 2013 Retina 13", OS X Mavericks with bootcamp/win7 and the install went very smoothly. btw Im pretty tec savy having built my own boxes with win and linux and figured out many things about win and how to do stuff under the bonnet so to speak.
    I'm happy with both installations and need both as many programs I use are not mac compatible but I have this problem with usb drives when in windoze.
    When plugging in usb drives, sticks and hard drives fairly often they don't show up, in My Computer, Manage Drives or Device Manager. I found that when this happens that if I reboot then they will show up.
    I recently bought 2 DataTraveler 32gb sticks figuring that the 8gb DT stick I already have works fine then these should too. After plugging them in they didn't show up so rebooted win7 but still didn't show tried reformatting them as NTFS and Exfat and Fat32 but no go. They work in Mac, Linux and in my win7 desktop no problem so not the sticks themselves, so I'm thinking this is a bootcamp problem. Intel usb drivers perhaps? I have tried everything I have found on the web including uninstalling those drivers and rebooting but to no avail.
    If I cant solve this then these 2 sticks are a waste as the whole purpose was to transfer files from the win7 MBP to other machines. eg in College, work or my desktop running win7 also.
    Has anybody come across this problem or seen a solution to it?
    Thanks in advance
    cheers A
     
  2. macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #2
    try to format one of the sticks with "rufus" ( windows freeware ). GPT partition scheme, FAT32 and see if the problem persists. Sticks fromatted like this can boot in my MBP.
     
  3. andrewdroid thread starter macrumors newbie

    Joined:
    Sep 25, 2014
    #3
    Thanks for that macenied but still no go they work in all my other machines/OS's but not in win7 on the MBP :mad:
    I think its the crappy intel drivers that mac supplies in bootcamp :(
     
  4. andrewdroid thread starter macrumors newbie

    Joined:
    Sep 25, 2014
    #4
    nobody had this problem before ? 480 views ??
    I now have exactly the same problem with a brand new Integrel 64gb USB3 stick which is so weird as I got a 32gb version that works OK
    really maybe its just my MBP and its really crap

    Im beginning to think that mac is just a con and a pricey one at that
    :eek:
     
  5. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #5
    Only thing I can suggest is that you always format your USB sticks on the Windows side. Or even better, on a full-fledged PC.
    Sticks formatted on my Mac, even to a Win-compatible format, always have problems being read by Windows afterward.
     
  6. andrewdroid thread starter macrumors newbie

    Joined:
    Sep 25, 2014
    #6
    mmm they alwaysv are :(
     

Share This Page