MBP - Brightness Keeps Changing

Discussion in 'MacBook Pro' started by superman666, Jul 12, 2007.

  1. superman666 macrumors regular

    Joined:
    Jun 25, 2007
    #1
    I guess I don't really have to explain. I own a 15 inch 2.4GHz MBP, and occasionally the backround automatically changes brightness. It's really annoying...Does anyone know how to stop that?

    Thanks
     
  2. AppleIntelRock macrumors 65816

    AppleIntelRock

    Joined:
    Aug 14, 2006
    #2
    do any conditions change when it happens? does the room get darker? do you go from plugged in to not?
     
  3. KristieMac macrumors 6502a

    KristieMac

    Joined:
    Jun 3, 2007
    Location:
    Harrisburg, PA
    #3
    You can try going to your system preferences > display and uncheck "automatically adjust brightness as ambient light changes"
     
  4. Hls811 macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #4
    Are you moving your hand (or anything) by the ambient light sensor under the speaker grill on the left hand side?

    You can disable that completely by hitting the F8 button..
     
  5. magius macrumors regular

    Joined:
    Jun 3, 2007
    #5
    go to system preferences, go to display, on the bottom is an option that says "automatically adjust brightness as ambient light changes," turn that off/uncheck it.

    edit: nevermind, apparently some people type faster than I
     
  6. iTim314 macrumors 6502

    Joined:
    Jun 5, 2005
    Location:
    U.S.
    #6
    The MacBook Pros have an ambient light sensor under the left and right speaker grill. In low light conditions, the backlight will dim to keep the strain off your eyes. This also activates the keyboards backlight.

    To Disable the Automatic Screen Brightness:
    Open System Preferences.
    Go to Displays, and click on the 'Display' Tab. At the very bottom is a check box 'Automatically Adjust Screen Brightness as ambient light changes.' Uncheck it.
     
  7. superman666 thread starter macrumors regular

    Joined:
    Jun 25, 2007
    #7
    Ahhh you guys are so quick! Thanks alot, I unchecked it :)
     
  8. AppleIntelRock macrumors 65816

    AppleIntelRock

    Joined:
    Aug 14, 2006
    #8
    that box is going to be lonely you know... without its check and all :(
     
  9. polycat33 macrumors 6502

    Joined:
    Jul 1, 2007
    Location:
    Alexandria, VA
    #9
    I have this too, however it changes suddenly when nothing has changed with the ambient light! I'll be sitting there surfing the net and suddenly the screen gets really really bright! A few seconds later sometimes it goes back. Very odd. Does unchecking the box affect the keyboard backlights coming on in low light?
     

Share This Page