MBP crashed and now SSD isn't recognised... :(

Discussion in 'MacBook Pro' started by Sammi :), Aug 26, 2012.

  1. Sammi :) macrumors member

    Joined:
    Dec 31, 2011
    Location:
    Sheffield, UK
    #1
    Hi all. Having some problems with my Crucial M4 SSD, I have it installed in the Optibay and it contains the OS and all of my apps.

    I've had it around five months now with no problems at all but this morning when I awakened my MBP from sleep, I got the neverending spinning beachball and ended up restarting by pushing the power button. Now my SSD isn't being recognised at all, only my HD which just contains my documents is.

    Any ideas on what I should do to fix this? :confused: If it helps I'm running Mountain Lion on a 13" late 2011 MBP.
     
  2. playsontheleft macrumors regular

    Joined:
    Jul 2, 2012
    #2
    How do you know it's recognising the HDD? Is it in a bootable state at all?
     
  3. Sammi :) thread starter macrumors member

    Joined:
    Dec 31, 2011
    Location:
    Sheffield, UK
    #3
    Yes it boots to the screen which allows me to access the disk utility, re-install the OS and restore from time machine. When I check my disks the HD appears but not the SSD.
     
  4. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #4
    Ive heard of a lot of M4s dying lately, kinda funny really considering people "love" them so much.

    Can you pull the drive out and reseat it? Maybe connect it to a USB Enclosure and connect it to another machine to see if it recognizes?
     
  5. Sammi :) thread starter macrumors member

    Joined:
    Dec 31, 2011
    Location:
    Sheffield, UK
    #5
    Fixed it. Opened up my MacBook and the ribbon cables had somehow detached themselves. Perhaps I should have tried this before posting... hmm. Glad it's not broken though. :)
     

Share This Page