MBP crashes in its sleep

Discussion in 'MacBook Pro' started by mw360, Mar 6, 2015.

  1. mw360 macrumors 65816

    mw360

    Joined:
    Aug 15, 2010
    #1
    Hi, I've a 2008 MBP and when I shut the lid it crashes. Not straight away, but at some point later or during the night.

    By crash, I mean the first thing I notice is that the fans are running. If I open the lid I can't wake it. I have to turn it off to restart it.

    It started the day I installed Yosemite.

    I originally thought it was time machine, but I've turned that off. I've turned off Dropbox, FLux too. I don't think I have anything else running like that. I've shut down all applications and it still happens virtually every time.

    It doesn't get a lot of use so I haven't the enthusiasm to go through a clean install. Any ideas?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    What happens if you put it to sleep by way of the apple menu?

    Also did you look at the console logs?

    if its Yosemite related, try a clean install or even downgrade.
     
  3. mw360 thread starter macrumors 65816

    mw360

    Joined:
    Aug 15, 2010
    #3
    Console has nothing of interest as far as I can see. Putting it to sleep via the menu seems to reduce the problem but not eliminate it. Although its hard to test when it takes hours to get a result.

    I'm unlikely to downgrade because I'm using this like a coalmine canary, seeing what problems Yosemite has before committing important machines to it.
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    Sounds to me like it IS enetering sleep but then being woken and at that point something either runs away causing unresponsiveness and heat/fans (is it hot at that point?), or it crashes when waking due to something unknown.

    Any other odd behaviour? If you boot from a cold start does it consistently boot cleanly or sometimes have issues?

    FWIW this sounds more like a HW issue on the machine than anything inherent in Yosemite, even if the start was coincidental.

    If you boot in Safe Mode and sleep it does it still exhibit this behaviour?
     
  5. mw360, Mar 6, 2015
    Last edited: Mar 6, 2015

    mw360 thread starter macrumors 65816

    mw360

    Joined:
    Aug 15, 2010
    #5
    Yep, maybe was hasty dismissing the console. Must have misread it last time. There are some clues here I think. Last night I closed the lid a little before midnight. Here it is waking up at a little after 1.30am to do its business. I found it the next morning with fans spinning and otherwise unresponsive. (And yes, very hot)

    The system has not other obvious quirks, and boots up fine and behaves reasonably for such on old thing.

    The RTC alarm and discover problems turn out to be a known issue that was fixed for many people by 10.10.2. Not fixed for me though. I'm going to try turning off Wake on Ethernet which reportedly helps.

    If that doesn't work I guess I have some more googling to do.

    EDIT: Found an Apple thread with the same problem. Looks like there a solution there too.

    https://discussions.apple.com/thread/6632465?start=0&tstart=0
     
  6. JamesPDX macrumors 65816

    JamesPDX

    Joined:
    Aug 26, 2014
    Location:
    USA
    #6
    Sleep Crashness

    Did you by any chance install an SSD and TRIM Enabler (or equivalent) and disable the Sleep Image? That'll do it. :eek:
     
  7. mw360 thread starter macrumors 65816

    mw360

    Joined:
    Aug 15, 2010
    #7
    Thanks but no, its still a spinning disk.

    ----------

    Seems like it might be related to it trying to write a hibernation image in order to go into low power sleep. Looks like somethings going wrong there.
     
  8. mw360 thread starter macrumors 65816

    mw360

    Joined:
    Aug 15, 2010
    #8
    Two successful sleep and wake cycles today, so turning off 'Wake for network access' in system prefs seems to have worked.

    I don't know why, and suspect I've cured a symptom not the cause, but this will do for the moment.
     

Share This Page