MBP create network, connect from iPhone - not working!

Discussion in 'Mac OS X Server, Xserve, and Networking' started by sfaust, Aug 13, 2009.

  1. sfaust macrumors newbie

    Joined:
    Aug 13, 2009
    #1
    I've been trying to create a wireless network on the MBP, and then connect to it from an iPhone so that I can transfer files when no external wireless networks are available. On the surface, it appears to work on the MBP side, but the iPhone can see it, appears connected, but never gives me the wireless symbol at the top of the screen.

    I'd really love to get this resolved since when I travel and don't have wireless access, which seems to happen often lately, I can't get an file off my laptop to the iPhone in order to mail it to my clients via the cell/3G network.

    Here is a detailed description of what I've done so far;

    Settings>Network>AirPort - in Network Name drop down I selected 'Create Network'. I named it Laptop_Net, left it at Automatic(11) for the channel, did not enable Require Password, clicked Ok.

    The AirPort showed a green dot on the left, and shows Self-Assigned IP with a good Wireless icon on the right. The AirPort icon on the top main menu bar changes from the standard wireless to a 'computer' icon inside. All 'appears' good.

    On the iPhone, I then go to Settings>Wi-Fi> and see the Wi-Fi shows not connected. I tap on it, and and under chose network I see the Laptop_Net and tap on it. Check mark appears to show its connected. I click on the arrow to see the details, and it shows an IP address (169.254.187.212) under the DHCP tap with a subnet (255.255.0.0).

    I do note that the IP and Subnet disappear, then reappear on a regular schedule (there for say 30 seconds or more, gone for about 15 seconds, then repeats the cycle. The checkmark in the Settings>Wi-Fi Choose a Network next to the Laptop_Net cycles in the same manner. Eventually after a couple cycles, it connects to one of the other wireless networks I have saved.

    At no time does the Wireless symbol appear in the top bar of the iPhone, just the signal strength, AT&T, and 3G symbols.

    MacBookPro, OSX, latest updates
    iPhone 3G 3.0, latest updates

    Any ideas on what I should check? Pointers to troubleshooting guides, etc?

    Thanks in advance,

    Stephen
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    You want to look into:
    System Preferences / Sharing / Internet

    Not create network. Hope that helps.
     
  3. sfaust thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #3
    I'm not sure how that would help me solve my problem, or do you think turning on internet sharing will help the two connect with a created network?

    Thanks,

    Stephen
     
  4. sfaust thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #4
    For anyone else in my shoes that can't get a AdHoc network setup, here is a link to the solution that fixed the problem I had. All is now well :) Thanks consultant for pointing me in the right direction! Not sure why i couldn't setup an AdHoc network without internet sharing, but I can still use the wireless between the iPhone and laptop even though there is no internet to share ;)

    http://discussions.apple.com/thread.jspa?threadID=2049667&tstart=0

    Here are the details;

    1 with airport on, open sharing under internet & network preferences

    2 highlight internet sharing (don't check the box yet)

    3 choose an option for 'share your connection from' - my imac is wired to my modem, so I opt for ethernet. if your mbp connects to a wireless router, i would choose airport.

    4 check a box for 'to computers using:' here the choice is airport

    5 click the 'airport options' button > here, whether or not you've created the adhoc network through any other means, it wouldn't hurt to fill the data fields again. on at least one occasion, the info here (password) was different than the password i created for the same ad hoc network i created through airport's taskbar menu > click ok

    6 check the box for internet sharing

    7 confirm that you want to start sharing

    8 the icon on the taskbar should fill in with an upward pointing arrow

    9 on the iphone, open wifi settings and choose the ssid name for the network and input the password (if you opted so for your network)

    This allowed me to create a wireless network, connect to it from the iPhone, transfer the files, then use the cellular network to e-mail them out (using iDisk or Quickoffice Files app on the iphone).

    Next time I get a call from a client for an estimate where I don't have any internet or wireless access, I can still get it to them as long as I have a cell signal.
     
  5. shadyMedia macrumors newbie

    Joined:
    Apr 6, 2009
    #5
    If your Using Firmware 3.0 It's a know in issue and Apple Is aware of it you will want to contact them and explain the issue
     
  6. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #6
    The reason is that enabling Internet Sharing also enables DHCP on the network you're giving access to (the WiFi); creating an AdHoc network does not. Had you nailed the IPs on both, it would have worked using an AdHoc network.
     
  7. sfaust thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #7
    I had considered trying to setup the IP's manually. But what threw me off was that IP addresses were automatically filled in the DHCP filed and I couldn't change them. So I assumed that DHCP was working, but there was some other problem. Now that I know it wasn't, it all comes into focus ;)
     
  8. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #8
    My guess is they were 169.254.x.x addresses. Those are self-assigned addresses, IP addresses systems assign to themselves to bring the IP stack up.

    If you have the NIC set for DHCP, you're not allowed to alter the settings.
     
  9. sfaust thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #9
    You don't need to guess, its right there in the first post ;) Yes, they were 169.254.x.x addresses, and it did show as self assigned.

    Thanks for the info, I wasn't aware of how that worked, and it will come in handy in the future.
     
  10. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #10
    That's what I get for posting late at night. :)
     
  11. sfaust thread starter macrumors newbie

    Joined:
    Aug 13, 2009
    #11
    Can't tell you how many times I've done the same thing! Well I could I guess, but would rather not ;)
     

Share This Page