MBP drops external display if power connecter removed

Discussion in 'MacBook Pro' started by convergent, Nov 24, 2008.

  1. convergent macrumors 68030

    convergent

    Joined:
    May 6, 2008
    Location:
    Raleigh, NC
    #1
    I've got a new Early 2008 MBP 2.6Ghz. I run it most of the time with a 30". The handoff between using the laptop and external display is still a bit "rough" and I've yet to find a consistent method that always works. One thing that is driving me crazy is that if for some reason I happen to knock the power cable loose from the MBP at any point, it abruptly drops the external display and I basically have to reboot to get it back. This has happened a couple of times while I was running it in clamshell mode. Is there some setting or something that would cause this?
     
  2. Hydroxs macrumors regular

    Joined:
    Jun 25, 2008
    Location:
    Atlanta
    #2
    You have to have the power cord plug in to use an external monitor. I think there is no work around for this.
     
  3. convergent thread starter macrumors 68030

    convergent

    Joined:
    May 6, 2008
    Location:
    Raleigh, NC
    #3
    OK... thanks. I didn't realize that. I guess it makes sense, but its kind of a pain when you knock it loose. I guess it wouldn't be so bad if there were some way to get it back into clamshell mode reliably. The only way that seems to work every time on that is power it on from scratch and close the lid quickly... which is not convenient when you are up in running. I'll live though, as I don't need to connect/disconnect that often and today I've started liking having the MBP display up and running in two display mode...
     

Share This Page