MBP early 2011 and thunderbolt external disk

Discussion in 'MacBook Pro' started by marcolin, Oct 9, 2013.

  1. marcolin macrumors newbie

    Joined:
    Oct 9, 2013
    #1
    ciao,
    i just bougth a Lacie Rugged external hard disk (1TB, Thuderbolt series).
    when i connect the drive to my early 2011 MacBookPro it doesn't show up on the desktop -- looks like the drive doesn't receive power from thunderbolt cable (led remains off)

    i am sure that the drive is ok because i tried the following:
    1) connected Lacie Rugged to my 2013 iMac via thunderbolt cable and it works = drive is ok, original thunderbolt cable is ok, drive gets power from thuderbolt port
    2) connected my MBP to another external thunderbolt drive and it works (this drive has external power) = thunderbolt port on MBP seems to work fine
    3) connected Lacie Rugged to my MBP via USB and it works = drive is ok, it receives power supply from USB port
    4) connected Lacie Rugged drive to my MBP with another thunderbolt cable that i am sure is fine and drive still doesn't get powered, disk won't mount = issue is not related to the cable

    it looks like thunderbolt port isn't capable to power external drive... but earlier today at local apple store i have been told that this portable drive was the best choice for my 2011 MBP... so anyone knows why is it not working?
    thanks in advance for your help
     
  2. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #2
    When connected through Thunderbolt does it show up in Disk Utility? I'm assuming no based on your information, but figured it was worth a shot. Also, how is the drive formatted?
     
  3. Doward macrumors 6502a

    Joined:
    Feb 21, 2013
    #3
    Try it via Thunderbolt on another computer - either your cable is bad, the port on the LaCie is bad, or the port on the Macbook Pro is bad.

    Thunderbolt cables are 'active' cables - they can go bad ;)
     
  4. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #4
    Did you actually read all of the original post?
     
  5. Doward macrumors 6502a

    Joined:
    Feb 21, 2013
    #5
    Skimmed, but thanks to your post I've now re-read it.

    To the OP, it sounds like the Thunderbolt port on your MBP is having issue - you should have no problem with Thunderbolt powering any single external drive - TB's spec is 10 watts.

    Sounds like a power issue in your MBP, being unable to supply the necessary 10 watts of power.
     
  6. marcolin, Oct 10, 2013
    Last edited: Oct 10, 2013

    marcolin thread starter macrumors newbie

    Joined:
    Oct 9, 2013
    #6
    solved

    thanks to everybody, solved.

    simply my MBP needed thunderbolt firmware update.

    i forgot to mention that my logic board has been just replaced by local apple store so i had to sort of "re-install" this update (my MBP was up to date before this replacement)

    now everything works great
     
  7. Doward macrumors 6502a

    Joined:
    Feb 21, 2013

Share This Page