mbp early 2011 usb hub problems

Discussion in 'MacBook Pro' started by kino, Jul 8, 2011.

  1. kino macrumors newbie

    Jul 8, 2011
    Need help. I have a very strange problem and i dont know is it a problem only with my mbp and i should send it to service or its overall problem.

    The thing is mbp 15" have 2 usb ports and i whanted to extand it with USB hub with own power support, problems comes 4-5 a day the mbp just shutdown all usb ports turn off the build in keyboard and touchpad but still works when i pull of all usb cables from it after 1-2 min it comes to normal and i can put the cables again until it occure again.

    I tested it with couple USB hubs and its the same:/ passive or active no matter.

    Please help because its very frustraiting 2 ports is no enough for me and this switch off is pain in the ass
  2. Apple 26.2 macrumors 6502a

    Apple 26.2

    Jan 1, 2011
    What up, 212?!
    How about trying a non-powered USB hub?

    Just a random thought, but give it a try.
  3. kino thread starter macrumors newbie

    Jul 8, 2011
    tryied that passive is without own power up:/
  4. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    Personally I find two USB ports plenty on my MBP, for me it was a matter of using BlueTooth, Firewire & Ethernet when possible.

    What sort of USB devices are you connecting?
  5. kino thread starter macrumors newbie

    Jul 8, 2011
    It all dependes what u need or u work on. I tryied 5 USB Hubs one my and 4 from my friends wich also work on MBP but late 2010 and they work, 3 of them are made in china (one of them is my) and 2 of them some dlink and 2nd cant remmber the name but also from hi-end
  6. kino thread starter macrumors newbie

    Jul 8, 2011

Share This Page