MBP fails to boot with new hard drive

Discussion in 'MacBook Pro' started by rarebear-nm, Jan 13, 2014.

  1. rarebear-nm macrumors newbie

    Joined:
    Jan 13, 2014
    #1
    I have two twin MBPs. One failed to boot showing the flashing folder & question mark. I do have good Time Machine BKs for this system. I placed a new non-apple HD (1TB). I formatted it as a apple extend file jounaled file system. Used a bootable USB with Disk Utility and downloaded and installed a fresh copy Lion. Then connected the Time Machine backup and restored to a desired point. Before a restart all looked good.

    After a restart I still get the flashing folder/?. Even pressing Option at restart fails to show the new HD as an option. I removed the new HD, attached it to the system via USB connector, selected Option at power up and was able to see the new HD and the system booted fine from it. But the system fails to boot if the HD is attached internally.

    I suspect that I missed or goofed on the GUID partition. Or was that automatically created when I did the Lion install?

    If I missed the GUID step, how can I fix it at this point? Either using some tool to write the GUID to the HD or starting over and reformat the new HD.

    Thanks for advice in advance.
     
  2. diazj3 macrumors 6502a

    Joined:
    Jan 19, 2008
    #2
    I also guess it's the lack of GUID partition...

    As far as I know it's not possible to fix it without reformatting the drive. But OS install is so fast it shouldn't be a problem - you'd be done by now if not for recurring to a forum.

    Just reboot form the USB, go to disk utilities there, repartition/format it and reinstall OS X.

    Cheers!
     
  3. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #3
    /\/\ This with GUID set
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    You problem is not GUID. If you did not have GUID the OS installer would not have worked. Read this. The fact you can put the same drive in an external USB case and boot from it proves that it is in the correct GUID format or it would not boot.

    You have something else going on. Perhaps a bad drive cable.
     
  5. rarebear-nm thread starter macrumors newbie

    Joined:
    Jan 13, 2014
    #5
    When I boot with the USB Recovery Disk and go to Disk Utility the new hard drive does not show in the left pane, the USB and RAM drives do. I attached the new HD to a working MBP, ran Disk Utility and confirmed that it was partitioned with GUID, bottom left corner info. Using Option at power up allows me to boot from the new HD on the working MBP.

    It looks to me like the new drive is fine, but I think there's an issue with HD controller and/or SATA cable. Any thoughts?
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    I agree - if the hard drive was not formatted GUID, then the installer would complain immediately.
    An internal cable failure is fairly common.
    The only way to test is to try replacing the cable. You know that the hard drive itself is good, because you can boot using an external connection, and it boots a different Mac, too.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Yep... sounds like the cable.

    Like DeltaMac says, that cable failing is fairly common. The logic board controller failing would be very uncommon. Unfortunately, replacing the cable is the only way to know for sure. :(
     
  8. Kuderer macrumors newbie

    Joined:
    Jan 14, 2014
    #8
    Hi all, I'm new here. Long time follower, first time poster.

    So I have a similar problem. I was getting the flashing file with the question mark on my 13" Macbook Pro from mid 2012. I have tried the disk utility, which worked once but now when I turn the computer on and hold Command and R at the same time to get to the disk utility, it does not even show the hard drive as being available to verify or repair.

    I figured it was a hard drive problem, but I took it out and put it into my old MacBook....the hard drive works just fine! Reading this topic I just took the hard drive and connected the USB part from my external hard drive to the internal hard drive, held option on startup, and it doesn't appear. I tried the same thing on my old computer as well, and nothing shows up regarding the USB hard drive.

    I'm sure that all sounds confusing, but does anyone have any ideas? I'm hoping its just a connector issue as previously mentioned. My USB cable may be bad - evidenced by it not appearing on either MacBook.

    Any other thoughts?

    I appreciate your help!
     

Share This Page