MBP Firewire ports died, does not shutdown/sleep any more

Discussion in 'MacBook Pro' started by Elo Everidge, Jan 23, 2008.

  1. Elo Everidge macrumors newbie

    Jan 23, 2008
    Berlin, Germany
    Both Firewire ports (400 and 800) on my Macbook Pro (Nov. 2006 model, 15", C2D) have stopped functioning. I have tried to connect several hard drives with several different cables and in several different chain configs but Leopard (10.5.1) fails to detect any of them.

    A day before I noticed that Firewire had stopped working, my MBP wouldn't go to sleep anymore and it hasn't ever since. The display goes black but the computer fails to switch off the fans and hard drive, even hours after setting it to sleep. I suspect the two problems are related as they came up at about the same time. Maybe some issue with the Firewire driver that prevents the MBP from going to sleep? Shutdown did work fine for a few days after I noticed these problems but now it shows the same symptoms: applications quit normally, the system seems to shut down ok, the screen goes blank, but then the computer does not turn itself off. The only way I can set an end to this is to hold down the power button or remove the battery.

    System Profiler, under FireWire, shows this: "FireWire Bus: Warning: Unable to list FireWire devices."

    The moment I click on Software -> Logs in System Profiler, Leopard crashes with a Kernel panic (this is reproducible, happens every time). From the crash log:

    Backtrace terminated-invalid frame pointer 0xbffff1f8
          Kernel loadable modules in backtrace (with dependencies):
                dependency: com.apple.iokit.IOFireWireFamily(3.3.8)@0x769000
                dependency: com.apple.iokit.IONetworkingFamily(1.6.0)@0x64c000
    BSD process name corresponding to current thread: ioreg
    Mac OS version:
    Kernel version:
    Darwin Kernel Version 9.1.0: Wed Oct 31 17:46:22 PDT 2007; root:xnu-1228.0.2~1/RELEASE_I386
    System model name: MacBookPro2,2 (Mac-F42187C8)
    From system.log during boot:

    Jan 23 09:38:23 localhost kernel[0]: FireWire (OHCI) TI ID 8025 built-in now active, GUID 0017f2fffe81baba; max speed s100.
    Jan 23 09:39:13 Tiefflieger kextd[10]: writing kernel link data to /var/run/mach.sym
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer: timed out waiting for IOKit to quiesce
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer: Busy services :
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2 [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0 [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PCIB@1E [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PCIB@1E/IOPCI2PCIBridge [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PCIB@1E/IOPCI2PCIBridge/FRWR@3 [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PCIB@1E/IOPCI2PCIBridge/FRWR@3/AppleFWOHCI [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PCIB@1E/IOPCI2PCIBridge/FRWR@3/AppleFWOHCI/IOFireWireController [1]
    Jan 23 09:39:29 Tiefflieger configd[33]: InterfaceNamer:   MacBookPro2,2/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PCIB@1E/IOPCI2PCIBridge/FRWR@3/AppleFWOHCI/IOFireWireController/IOFireWireLocalNode [1]
    Jan 23 09:39:37 Tiefflieger loginwindow[23]: Login Window Started Security Agent
    I've been running Leopard on this machine without problems for the last 2 months. I can't think of any change in the software environment I have made recently.

    To me, everything looks very much like a hardware failure, doesn't? Any other ideas? Has anybody had this problem before?

    Thanks so much for any suggestions.
  2. DocSmitty macrumors regular

    Jan 7, 2008
    Lincoln, NE
    Do you have any time machine backups to just before the problems occurred? That would be the best way to sort software v. hardware. It does sound like hardware to me.

    Do you have AppleCare? Is there an Apple store nearby you can visit? Can have it checked out and see what the verdict is..
  3. Elo Everidge thread starter macrumors newbie

    Jan 23, 2008
    Berlin, Germany
    Thanks for the suggestions. Yes, I do have recent backups but didn't have a close look at them. It does seem difficult to look for differences between two Time Machine backups when you don't know in which folders to look but now that you mention it I could probably compare the directory trees directly with FileMerge or diff. I might try that.

    Yes, that's what I'll probably do next. I'm in Germany, we have no Apple Stores, I'll have to bring it to an Apple-authorized service provider.
  4. mgsarch macrumors regular

    Jan 19, 2008

    Elo, I feel your pain. I've had the EXACT same issue down to the ConfigD message. If I boot in Verbose I can see it first happening. I've had this problem for nearly year and can't send my MBP in for service because it's my only means of doing work. I'm hoping to take a break in a couple weeks and send it in. This situation has driven me insane looking for a fix. I think you're right though- it's hardware.

    If you do some searching you'll find many many people with the similar issue. Yours with the Sleep/Firewire combo is identical to me though.

    I wish I had good news. :(

    Please be sure to post if you somehow resolve this. (Or if you figure out how to disable the firewire port so we can at least not have these malfunctions.) It's bad enough it can't sleep or use firewire- drives me mad how it seems to be stalling up everything else on it's way down ...

    take care.


  5. mgsarch macrumors regular

    Jan 19, 2008


    I had the problem back in Tiger (hence year ago). It started only a month after purchase and I've run through the routine with AppleCare several times. They have no idea and their responses have gotten more unintelligible with each call. I think it has to be hardware.

    Also, Tiger actually would shutdown. Leopard goes all black with the fans running. (Have you noticed heat increases? My CPU gets up to 90C while I'm doing renderings. Quite scary ... and hot!!!!)
  6. Elo Everidge thread starter macrumors newbie

    Jan 23, 2008
    Berlin, Germany
    Thanks for your reply, mgsarch. I'm convinced it is a hardware issue. Here's how I managed to disable the FW ports:

    (1) Go to /System/Library/Extensions and move these files to a backup folder on your desktop (or anywhere else):
    You will need your admin password for this.

    (2) Reboot. Mac OS won't attempt to load the FW drivers and with this all problems have gone away for me. The FW ports are still dead of course, but everything else works, including shutdown and sleep.

    System Profiler now says, "No FireWire ports can be detected."

    Let me know if this works for you.
  7. mgsarch macrumors regular

    Jan 19, 2008
    I did a terrible thing not responding to this thread, I thought it was on the apple forums and I just found it in my subscribed threads.

    Elo, you are a genius. You saved me during a crucial time of work! This made my MBP run 10x faster. I couldn't believe it when it booted up.

    I've sent it back now and I'll get a brand new one sometime soon I hope. I have spread the word about this to some others I know were also affected.
  8. Elo Everidge thread starter macrumors newbie

    Jan 23, 2008
    Berlin, Germany
  9. seamlessnovelty macrumors newbie

    Mar 31, 2008
    Thank you!

    I have precisely this same issue on my MBP 15". I removed the Firewire extensions and now the system at least boots quickly. Thank you so much for tracking this down, it's been driving me nuts.
  10. mgsarch macrumors regular

    Jan 19, 2008
    Elo really deserves huge thanks from me. I'm glad another victim has found this thread!!!

    My MBP is in Apple's hands (finally). But the workaround made it usable for the interim.
  11. Ryuukumori macrumors 6502

    Jan 18, 2008
    So Elo, did you ever get it under warranty or checked out about your firewire and other hardware problems?
  12. andynrg macrumors newbie

    May 22, 2008
    Firewire Dead

    Hi Everybody. I had the same problems with firewire which has become not avaible in a moment. I didn't understand why,but that's what happend. Now,deleting all firewire.kext from extensions folder will solve really the sleep problem and also the multitouchpad for those who have the new MBP generation but it will also permanently disable using firewire on your computer. What i did was deleting only IOFirewireIP.kext. This has repaired the sleep problem and also booting which was taking 20 minutes to me. I bought then a Tango Exprescard34 from Sonnet (you can find it on BHPHOTOVIDEO also for 53 box) and when plugged in ,your firewire becomes active only for Firewire 400 sure because this what can Tango Exprescard34 from Sonnet offer. At least,you save to your self,the possibility to still use firewire. Connected a WD 1TB unit and it worked perfectly. Hope this helped people that just like me was going crazy about this really STRANGE hardware problem.
  13. milopus macrumors newbie

    Jun 22, 2008
    thanks so much

    This worked for me. Thanks so much. I knew that there had to be a way to do this. When I was trying to figure out what was wrong with my computer, I was sure that it had to be software related. But before reinstalling the system, I wanted to be sure...so I searched the internet to find if others had a similar problem. So thank you for the temporary fix to the computer. Now I have to figure out how to get it fixed under warranty here in Bangkok.
  14. macfanat1c macrumors newbie

    Jul 6, 2008
    luving Elo

    My old Titanium Powerbook is slowly biting the dust and the firewire port went. It kept the machine from sleeping and was driving me crazy! The machine ran instantly HOT as soon as it booted up.

    Your tip solved those 2 problems and helped me salvage this machine and extend its life. i can still use it to demo files as long as i transfer them to the hard drive via usb or get a card for the slot and re-enable the extensions so I still have a decent on the road basics machine.

    SO I can invest my money in a more powerful desktop machine at home to be my workhorse!

    Is there any software that allows you to easily turn extensions on and off like there was in OS9?
  15. milopus macrumors newbie

    Jun 22, 2008
    new problem

    Okay, so they fixed me under Apple warranty here in Bangkok, Thailand (the MBP was bought in the US) in just about a week. They said that they had to replace my logic board.

    So the firewire port is now working as the computer can recognize an external firewire boot drive. However, after I replaced my firewire extensions back into the "extensions" folder, there is a normal start-up for the computer, but then I get error messages saying that the firewire extensions were not installed correctly and the firewire does not work nor does it show up on my System Profiler.

    Do I have to reinstall my whole system? Or is there something that I can do to fix how those extensions should be moved back?

  16. milopus macrumors newbie

    Jun 22, 2008

    Oops, forgot to repair permissions after reinstalling the extensions back into the system folder.

    Like new.

    Thanks for a great tip! Very helpful. It works like a charm.
  17. samlic macrumors newbie

    Nov 16, 2007
    no joy

    I have exactly the same problem, my MBP is the merom version that I bought in Nov,2006. The firewire port died on 13 November,2008.

    It says in the Hardware Profile:
    Warning: Unable to list FireWire devices.

    And I have got the same error when I boot into verbose mode.

    I carelessly drown my table and some water went into the DVI port and the firewire port, as soon as I restart the machine again, it takes 6 mins to boot and it doesn't go to sleep or shutdown.

    I am not sure if it's really because of the water, as I am working in a video studio and we have to use the firewire 800 to transfer hundred gigs of data in and out everyday. But if it died because of my heavy use, I am satisfied and it lasted for exactly two years now. Tho, I didn't get the Apple care and Apple quote the logic board price of £645! I can get a new uni-body MBP with just £1200.

    So I guess I will get a belkin Firewire 800 express card for my MBP, but I am wonder if the express port has enough power to drive the Lacie "little big disk"( normally the "little big disk" can run on firewire 800 with additional power adaptor at full speed 7200RPM and enough to edit HDV. )

    Thanks for the previous post!
  18. milopus macrumors newbie

    Jun 22, 2008
    actually, my MBP was still under warranty, and they told me that my logic board got fried. They replaced that for me, and it has worked fine since then.

    Oh, I forgot one thing. I had to remember to put these extensions back into place, then I had to repair permissions. Then it worked fine.

Share This Page