MBP freezing

Discussion in 'MacBook Pro' started by ej00262, Apr 10, 2012.

  1. ej00262 macrumors newbie

    Joined:
    Feb 15, 2012
    #1
    Hey forum,

    Recently my MBP's (mid 2007, 2.16 GHz C2D, 4GB RAM, 7200RPM 500GB HDD, OSX Lion) battery died while using it, not put to sleep but actually shut off for lack of power. This isn't extremely uncommon for me because the battery is pretty old (2010). However, thanks to Lion's flaw, jk feature, of restoring apps to their state before shutdown, my MBP will attempt to restore my 6 apps running (Preview, MS Word, Safari, iTunes, Mail, Finder) each time I attempt to reboot my computer. After successful login, the MBP freezes and won't respond to anything. No forcequit, nothing. I see the pinwheel of death until I finally resolve to force shutdown by holding the power button. Restarts following that change nothing. I've restored the OS by holding CMD + R, removed and reinstalled the RAM, and drained the battery. Nothing helps. Anyone have any ideas how to fix this?? I haven't backed up very recently so a full restore is the undesired, albeit final option.
     
  2. sweetbrat macrumors 65816

    sweetbrat

    Joined:
    Jun 17, 2009
    Location:
    Redford, MI
    #2
    I *think* you might be able to hold down shift as you're logging in (basically as soon as you enter your password and start the login process). I've heard that it will prevent things from resuming, but I haven't tried it to know for sure. That's my best guess; I'm on a computer running Snow Leopard right now so I can't test it out myself.
     
  3. ej00262 thread starter macrumors newbie

    Joined:
    Feb 15, 2012
    #3
    That actually worked. I've looked for ages for that type of command, thank you so much! After a long spotlight indexing, it appears I'm back up and running!

    Few notes, when I did get it working, my dock was reset to factory settings for some reason, I swear my icons on my desktop look smaller, and I received a weird popup about Java instructing me to install the Java runtime immediately upon the restart. (Ran the terminal commands to ensure I didn't have the Flashback and I don't)
     
  4. ej00262 thread starter macrumors newbie

    Joined:
    Feb 15, 2012
    #4
    Thinking more about it, I believe the dock was reset because I restored my OS with the CMD + R
     

Share This Page