MBP geforce 330m problems

Discussion in 'MacBook Pro' started by Tex-Twil, Jan 10, 2015.

  1. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #1
    Hi,
    I have a 2010 MBP but recently I started having issues with the geforce gt 330m card. Everytime the mbp starts using this card, the colors become washed.

    Is there anything I can try to do to fix this or is my MBP just dying?

    cheers
    Tex
     
  2. AlexMaximus macrumors 6502

    AlexMaximus

    Joined:
    Aug 15, 2006
    Location:
    A400M Base
    #2
    MBP 2010 and Yosemite

    Got the same machine. Keep me updated on this problem. Do you have any pictures? What do you mean by "washed out" colours?

    I had a graphic glitch with hexagons all over the screen and a freeze up, because I used the wrong Win7 64 bit version on Parallels 10. Obviously Parallels only permits 32bit versions only.

    - Which programs do you use?
    - Do you use gfx utility to force the dedicated card?
    - Do you use Trim utility or not?

    You will keep running into problems if you have less then 8GB Ram with Yosemite. That`s what I can report from my experience with Yosemite.

    :apple:
     
  3. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #3
    on the left photo the screen is kind of blueisch. It's not so niticable on the photos but in real the difference is huge.
     

    Attached Files:

  4. AlexMaximus macrumors 6502

    AlexMaximus

    Joined:
    Aug 15, 2006
    Location:
    A400M Base
    #4
    Screen calibration, colour profile in settings..

    That was quick, thanks for the pics. I had gpu problems before but on windows pc's only. To me it does NOT look like your gpu is crapping out on you. Its more like a calibration thing or a somehow wrong colour profile or something like that.
    When the gpu dies it used to have lines from right to left or artefacts or some other weird glitches. I think there is still hope for you.
    Make sure you check different setting in the Display section. You may tray different profiles like AGB or Adobe settings. Contact your local Apple store or Adobe dealer for a screen calibration. To me it looks like a colour temperature thing or something. The 330M was the best option at that time, I never had any problems so far except my wrong win7 64bit / parallels combination.

    :apple:
     
  5. Tex-Twil, Jan 11, 2015
    Last edited: Jan 11, 2015

    Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #5
    I tried changing the color profiles but they all look blue. It does not look like a color profile issue.

    I tried reseting the PRAM, quitting gfxCardStatus, restarting .. :(
     
  6. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
  7. AlexMaximus macrumors 6502

    AlexMaximus

    Joined:
    Aug 15, 2006
    Location:
    A400M Base
    #7
    You are the man..


    The BIT from TRON says:

    YES YES YES YES YES YES YES YES YES YES YES YES ....

    :):):):):):):):):):)

    many greetings from planet Woodstock....
     

Share This Page