MBP hangs on wake-up with external display

Discussion in 'OS X Mountain Lion (10.8)' started by dops7107, Nov 17, 2012.

  1. dops7107 macrumors 6502a

    dops7107

    Joined:
    Mar 19, 2005
    Location:
    Perth, Oztrailya
    #1
    This happens reproducibly with two MBPs (one cMBP 2012, the other a 2008 pre-unibody) running 10.8.2:

    1. Connect external monitor (ACD 20 inch) via DVI, using TB->DVI adapter where necessary

    2. Put computer to sleep using power button or sleep from Apple menu

    3. Close lid of MBP after sleep has taken place

    3. Put human to sleep by going home/to bed

    4. Come back to computer and open lid to wake.

    What do I find? Even before I open the lid, the computer is hot to the touch and the fans running high, but otherwise totally unresponsive. Displays are either blank or I see the password prompt. I have to hard reboot the machine to get it working again.

    Can anyone replicate this issue? The machine has no problems with long-term sleep without an external monitor attached. I think it might depend on the MBP going into "deep sleep" because a brief 2-3 minute sleep and wake cycle as above works fine. I will now try to wait half an hour or so and see what happens.
     
  2. dops7107 thread starter macrumors 6502a

    dops7107

    Joined:
    Mar 19, 2005
    Location:
    Perth, Oztrailya
    #2
    Forgot to mention, this is specific to closing the lid. If I put it to sleep without closing the lid, it wakes up fine every time.

    And after 25 minutes of sleep with lid shut, no probs. At some point it must "wake up" with the lid closed because the fans come on.
     
  3. Joseph Farrugia macrumors regular

    Joined:
    Jul 31, 2011
    Location:
    Malta (EU)
    #3
    Yet another ML bug

    Yet another ML bug that the Lion/ML apologists have no answer to.

    Anyone?
     

Share This Page