MBP having problems for the first time

Discussion in 'MacBook Pro' started by yk2366, Jul 5, 2010.

  1. yk2366 macrumors member

    Joined:
    May 5, 2010
    #1
    It's been around two months since i bought my MBP and it worked well until this morning.

    The internet just stopped working, despite its status as "connected" on the menu bar. I tried restarting, re-connecting to the internet, using a different browser, checking my other PC notebooks and they were connecting normally as usual. The network utility and the menu bar states that I have a full bar and it is connected, yet the internet does not work.

    While I was trying to figure out the internet problem, my charger that I've had connected to the computer begin to re-charge showing that there would be 15 min for the recharging to complete. This would be completely normal under the circumstance that I had my MBP unplugged for few minutes, but it was connected for the last week. My question is, how is the battery being charged when it is not being used at all? I thought after charging the battery, the MBP works straight off the electricity, not the battery.

    Any help or answers would be greatly appreciated!
     
  2. mdavies macrumors newbie

    Joined:
    Jun 8, 2010
    #2
    Are you connecting wirelessly? If so, try restarting your modem. I've had weird problems like that before, and I think that's how I solved it. Try turning you Airport off, then turning it back on. If that doesn't work, try shutting down, then while holding the shift key down, push the power button. The computer can take up to 15 minutes to boot up. It boots up in Safe Mode which will do some extra stuff which could possibly fix your problem. Then restart again. Also, what OS are you using?
     

Share This Page