MBP keeps forgetting my wifi

Discussion in 'MacBook Pro' started by Tainter, Jun 26, 2010.

  1. Tainter macrumors member

    Joined:
    Nov 30, 2008
    #1
    I know this has been discussed before but is there any solution to this ?

    Evey time it goes to sleep or i turn it off it forgets the fact that there is ANY wireless around. I have to look for the networks. Then if it wants to will find them and trying to connect to my own wireless network ( apple extreme) is a challenge .

    I do have parallel desktop installed , could that be the problem ? ANY hints ?
    here is some info


    Model Name: MacBook Pro
    Model Identifier: MacBookPro5,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 4 GB
    Bus Speed: 1.07 GHz

    System Version: Mac OS X 10.6.4 (10F569)
    Kernel Version: Darwin 10.4.0
    Boot Volume: Macintosh HD
    Boot Mode: Normal
     
  2. bigjobby macrumors 65816

    Joined:
    Apr 7, 2010
    Location:
    London, UK
    #2
    System Preferences>Network>Highlight Airport, click Advanced>check 'Remember networks this computer has joined'
     
  3. Tainter thread starter macrumors member

    Joined:
    Nov 30, 2008
    #3
    done that about 20 times.. no luck:mad:
     
  4. Kahalu'u Bob macrumors 6502a

    Kahalu'u Bob

    Joined:
    Aug 9, 2007
    Location:
    Honolulu
    #4
  5. davige macrumors member

    Joined:
    Apr 10, 2010
    #5
    Go to Applications/Utilities/Keychain Access/Log In Keychain/Passwords. Delete any references to your wifi network and start over. I had the same problem with an old PowerBook and that fixed it.
     
  6. Tainter thread starter macrumors member

    Joined:
    Nov 30, 2008
    #6
    thanks but that did not work either .....

    it always drops the
    isp
    server
    Internet.

    i almost gave up using it since it forgets the internet about every 5 minutes now.

    It scans for wireless networks , but it finds NONE. after a while it finds them i join my home network and it starts all over.

    It is not my router since my xbox 360 and my iphone have no problem staying connected for hours . Any other hints ?
     
  7. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #7
    I'd try power cycling your router and modem. Sounds like an overlapping of IP addresses.
     
  8. Kahalu'u Bob macrumors 6502a

    Kahalu'u Bob

    Joined:
    Aug 9, 2007
    Location:
    Honolulu
    #8
    Are you sure it is not your router? Have you tried taking it to another wifi spot? Even the local Starbucks should give you a baseline. If it works there, it is your router. If not, sorry, you've still got work to do with the Mac. But I think it would be worth the trip to rule out the router as the source of the problem.
     
  9. bigjobby macrumors 65816

    Joined:
    Apr 7, 2010
    Location:
    London, UK
    #9
    My mbp didn't tell me when I had an IP conflict and I had the same symptoms as the OP. For me it was all resolved by resetting the router back to default settings, reconfigure and reserving an IP for the mbp at the router. Might be worth the OP giving this a shot.
     
  10. Tainter thread starter macrumors member

    Joined:
    Nov 30, 2008
    #10
    Thanks all i will try that.
    How do i reserve and Ip for my MBP ? Thanks so much guys
     
  11. Tainter thread starter macrumors member

    Joined:
    Nov 30, 2008
    #11
    I set the router to channel 10 instead of Automatic and that seem to have solved the problem . thanks for all the help :)
     

Share This Page