MBP keeps on scrolling to end of page/ document

Discussion in 'MacBook Pro' started by PatsyStone, Jun 20, 2011.

  1. PatsyStone macrumors newbie

    Joined:
    Jun 20, 2011
    Location:
    Holland South
    #1
    Hi

    I have my MBP now for about 5 yrs and it has been performing like a star! Today I have been working on it like I usually do, nothing new.
    Then Adobe Acrobat told me a new update was available. I attempted to install the new update, but was toldby Acrobat notifier that something was wrong so the installation did not succeed. Unfortunately I can't remember what was the problem withholding Acrobat from completing the update.

    Then I switched my MBP off for a couple of hours after I was done working. Switched it back on a couple of hours later and then this:
    I opened an Adobe Illustration document to continue working on - then my MBP just continued scrolling the document all the way to the bottom even after I lifted my fingers from the trackpad / pen from the tablet.

    The same thing happens in ALL applications: Firefox, the download list, iTunes. The entire MBP just keeps on scrolling to the bottom as soon as I move the cursor over the area.

    After restarting a couple of times it seems that the problem had dissappeared, but then it came back again. I tried to restart again 3 times and then my MBP returned to normal. Otherwise I wouldn't be able to type this ;)

    I have deselected Firefox--> Preferences--> Advanced--> Use autoscrolling/ Use smoothscrolling. Does anybody have any idea what could be causing this erractic scrolling behaviour? And does anybody have some advise on how I can disable this?

    Thank you in advance!
     
  2. awer25 macrumors 65816

    awer25

    Joined:
    Apr 30, 2011
  3. PatsyStone thread starter macrumors newbie

    Joined:
    Jun 20, 2011
    Location:
    Holland South
    #3
    I keep my MBP immaculate, and if you read my entire message you would have seen that it also happens with my tablet. So I guess my track pad isn't the culprit. But thank you for the advise.
     
  4. travershartston macrumors newbie

    Joined:
    May 9, 2011
    Location:
    Caribbean
    #4
    Go to finder and then to Applications, form there go to the Utilities folder, in that folder is a program called Disk Utility open that program. When it opens click the button that says 'Repair Disk Permissions', its in the bottom right hand corner of the window. if you have never done this before it may take up to an hour to finnish. When it finishes the problem should be gone.
    When you do a software update it pays to do this. i usually repair my permissions every month just to be safe.
    Hope this helped
    *Prodigy*
     
  5. PatsyStone thread starter macrumors newbie

    Joined:
    Jun 20, 2011
    Location:
    Holland South
    #5
    Thank you for the advise Prodigy, I followed it but unfortunately no improvement! The ghost scrolling continues! Any more ideas? Thanks!
     

Share This Page