MBP late '06 CPU throttling problem

Discussion in 'MacBook Pro' started by oasf, Jan 8, 2011.

  1. oasf, Jan 8, 2011
    Last edited: Jan 8, 2011

    oasf macrumors newbie

    Joined:
    Jan 8, 2011
    #1
    Hello, guys!
    Inherited an old (late '06) MBP from a family member and the machine has seemed to work flawlessly since I got it, until I decided to do a boot camp install of win 7, so I could play som FO:NV.. When tried to play, the machine was laggy as hell, and when I ran win experience index I noticed the CPU was rated way below what it was supposed to. After some confusion I installed CPU-Z, where I noticed that the CPU was on the lowest throttle setting (977 MHz), even on full load. I have tried all kinds of chipset driver updates etc, as I thought it was a problem in Win 7 (which is unsupported on this machine), but on booting into OSX SL I noticed that its the same situation there. I have tried various apps, like CoolBook, to no avail. The CPU seems to be in good shape, as the temperatures are low and steady, and the stress tests all run well (although on lowest multiplier/voltage)

    Any ideas anyone?

    EDIT: And by the way:
    It also has a faulty battery, at under 150 cycles.. I guess it's too late for return...?
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    If the CPU is throttling itself, it's likely that it's overheating because of dust build up. You might ask why this doesn't happen in OS X, the only answer I can give is that the drivers are already optimized so there isn't that much heat vs. running in Windows.
     
  3. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #3
    There is a hardware failsafe where if the battery is not present or in an acceptable working condition, it will downclock the cpu and memory. CPU is downclocked to 1Ghz.

    Try with a working battery and see if problem remains.
     
  4. oasf thread starter macrumors newbie

    Joined:
    Jan 8, 2011
    #4
    Thanks for replies!

    @iLog.Genius:
    The problem is the same in both Win and OSX: It wont throttle at all. It is stuck at lowest clock speed. In windows I can change power settings, but to no effect. In OSX/CoolBook, all options are grayed out...

    @Animalk:
    It might be the battery is causing this, but the battery shows in system profile and in windows device manager, only it shows as dead and "in need of service"...

    I am just hoping its not the logic board. It is the northbridge that controls speedstep, right? And if so, is the northbridge on the logic board?
    Is there any way to manipulate the EFI, in order to disable speedstep at HW -level? (I am assuming the EFI controls the chipset, just as a BIOS would on a PC)
     
  5. farmermac macrumors 6502a

    Joined:
    Jul 23, 2009
    Location:
    Iowa
    #5
    You need to re-read Animalk's post.
     
  6. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #6
    I know if there is no battery present at all, the CPU will down clock but I don't think it's true with a battery that is in need of service (basically isn't able to hold a charge). I'm running on a battery which needs to be replaced and I'm experiencing no such throttling of CPU.

    To OP: are you noticing this running on the battery or is this happening when you're connected to power as well?
     
  7. oasf, Jan 9, 2011
    Last edited: Jan 9, 2011

    oasf thread starter macrumors newbie

    Joined:
    Jan 8, 2011
    #7
    The battery is ... strange ...
    The machine, both in win and osx, communicates with the battery firmware, so it knows its there, it just holds no charge:

    Battery Information:

    Model Information:
    Manufacturer: Sony
    Device name: ASMB012
    Pack Lot Code: 0003
    PCB Lot Code: 0000
    Firmware Version: 102a
    Hardware Revision: 0400
    Cell Revision: 0303
    Charge Information:
    Charge remaining (mAh): 0
    Fully charged: No
    Charging: No
    Full charge capacity (mAh): 0
    Health Information:
    Cycle count: 157
    Condition: Replace Now
    Battery Installed: Yes
    Amperage (mA): 0
    Voltage (mV): 7982

    It would be interesting to know apples motives for killing your computers performance in such a way, when no battery is present... I have read somewhere that it is for cooling purposes, since the battery's surface helps disperse heat, although this seems strange to me, since the last thing you want to do is to excessively heat a battery... (Apple has the only engineers of all the laptop producers I have bought laptops from, who seem to have an IQ-level over that of a monkey..) Both my compaq and my dell is unable to function without cooling peripherals, due to air-intakes being placed under the laptop.. You know, the side that is blocked by the table:p) .. My 5000$ dell fried its RAM 5 mnts after I bought it, and my 400$ compaq burns my finger (like in potentially giving you a blister) if I touch the VGA port after long, heavy use...

    EDIT:
    Heres Apples reasoning, which is retarded:
    "If the battery is removed from a MacBook or MacBook Pro, the computer will automatically reduce the processor speed. This prevents the computer from shutting down if it demands more power than the A/C adapter alone can provide."

    http://gigaom.com/mobile/run-your-macboo/

    It seems like its the battery that is causing this after all, then
     

Share This Page