MBP (late 2008) screen flickering

Discussion in 'MacBook Pro' started by hsl, Jan 23, 2011.

  1. hsl macrumors regular

    Joined:
    Dec 15, 2006
    #1
    Hi,

    I have the most annoying problem on my MBP, I only have it with the screen in the MBP, if I use any external screen I don't have the problem.

    When using the 9400M which is a lot better for the batterylife the screen turns off for half of a second every few minutes. Quite annoying.

    Anyone else has this problem?

    Thx,

    Harold
     
  2. hammie14 macrumors regular

    hammie14

    Joined:
    Mar 18, 2010
    Location:
    London, UK
    #2
    I have the same problem about 2 months ago, Apple replaced the Logic Board as they said it was an Nvidia chip problem.

    While changing the board i was told the tech who worked on the machine broke the screen lead and the screen did not work, so they replaced the screen too!

    Like mine was under applecare so did not pay for it! :D

    Good luck with yours, hope you have apple care as the logic board to replace is about £700 (i'm in the uk)
     
  3. Merkava_4, Jan 23, 2011
    Last edited: Jan 23, 2011

    Merkava_4 macrumors 6502a

    Joined:
    Sep 4, 2010
    Location:
    California
  4. hsl thread starter macrumors regular

    Joined:
    Dec 15, 2006
    #4
    thanks,.. but since it's a late 2008 unibody I guess it's not the other common nvidea problem.

    And another question,.. If it's a videocard problem, wouldn't I have the same problem when I have a external display attached?
     

Share This Page