MBP - Loses Wireless Connection Each Time It 'Sleeps'

Discussion in 'MacBook Pro' started by korpanopoly, Mar 11, 2008.

  1. korpanopoly macrumors newbie

    Joined:
    Mar 4, 2008
    #1
    Hello All,

    I am a recent Mac convert - I just purchased the stock 15" MBP last week.

    I have run into a strange issue recently (it started today actually). Each time my MBP goes into sleep mode, I lose the connection to my wireless network. As I mentioned, it worked fine for about a week and now today this issue started.

    When I try to access the Internet via Safari I get this message: "You are not connected to the Internet".

    I then click on the "Network Diagnostics" button and under "Network Status" I see the following:

    AirPort - Green Light
    Airport Settings - Green Light
    Network Settings - Yellow / Amber Light
    ISP (Failed) - Red Light
    Internet (Failed) - Red Light
    Server (Failed) - Red Light

    While I am getting the above, I still have full, uninterrupted access to the network on my PC.

    I then continue on within the Network Diagnostics window and reselct my network, enter in my network password, and then all of a sudden all is good again and I have access to the Internet and it says "Your Internet connection appears to be working correctly."

    The strange thing is that this happens everytime I wake my Mac up from sleep mode.

    I am sorry for the long post, but can anyone help me out?

    Much appreciated!
     
  2. BowZinger macrumors member

    Joined:
    Dec 8, 2007
    #2
    Check to make sure your router has the lastest firmware if you are not sure how to check find the documentation on your router...if you search for this problem there are lots and lots of threads about it try searching and going through them and see if they have found a fix for it!

     
  3. rezonat0r macrumors 6502

    Joined:
    Nov 2, 2007
    #3
    Yep sounds like a router issue. Upgrade or reboot the router (or try a different router temporarily) to see if that has any effect.
     
  4. korpanopoly thread starter macrumors newbie

    Joined:
    Mar 4, 2008
    #4
    Thank you very much for the replies.

    I thought myself that the issue may have something to do with the router, however, it has worked absolutely flawlessly since setting-up the router on Thursday.

    This issue just started this afternoon - it's not like I have been having this problem from the very start.

    Does this change your opinion of the cause of my problems?

    Thanks again!
     
  5. BowZinger macrumors member

    Joined:
    Dec 8, 2007
    #5
    Personally, I would still look into making sure your firmware on the router is up to date...it is possible that it may be causing an issue now rather than earlier.

    Also you may want to check out some of the threads both on here and Apple Support Discussion Forum (on the apple site). Lots of people have talked about this issue but I do not know if there is a "cure" as of yet.

    Also make sure you have all the available updates on your mac...

    You can do so by clicking the blue apple in the upper left corner and then clicking software update...if there are any "intel mac" updates or some kind of wireless updates I would install those (and any others that show up).

    Hope this helps!

     
  6. BowZinger macrumors member

    Joined:
    Dec 8, 2007
    #6
    Also, are you running a protected network? Such as WEP encryption or WPA with TKIP and AES?
     
  7. korpanopoly thread starter macrumors newbie

    Joined:
    Mar 4, 2008
    #7
    Yep, WEP encryption (I think). I do have to enter a password to access my network.

    As for "WPA with TKIP and AES", I truthfully have absolutely no idea what you are talking about!:D

    Thank you for replying to my post.
     
  8. BowZinger macrumors member

    Joined:
    Dec 8, 2007
    #8
    No worries about the WPA part, that is just another way to protect your WIFI that is a bit stronger that WEP...anyways,

    I do not really know what else to suggest....I have read a few threads in which people have had problems with their mac connecting to a WPA protected router but since yours is using WEP I have no idea....

    One more suggestion is to unplug your modem and your router for like 5 minutes and then plug the modem back in wait for all the lights to stay on (or look like they do in a normal state) and then plug in the router and wait for the same thing...that may fix the problem

    Another thing to do is maybe run the "Network Setup Assistant"

    you can get to that by clicking on System Preferences (the icon on your dock that looks like a light switch with an :apple:) and then highlight "airport" and then click on the assist me button down at the bottom...

    And if that doesn't do it, then I would think about calling up apple and letting them know whats happening.

    It may be a issue with your macbook alone or it may be the issue that lots are facing.

    I hope that this may help!

     
  9. sjb macrumors regular

    Joined:
    Jul 3, 2007
    #9
    My new MBP has problems connecting to my 802.1x WPA2 (AES) network at work after coming out of sleep. If I connect to the wireless it works just fine, but after I sleep and then wake the laptop, it will say it is connected, but I will have a private IP address and not one assigned via DHCP (which I believe may be the yellow light the thread starter mentioned). If I 'Turn Airport Off' and then turn it back on, it connects just fine.

    On my home network using WEP128, I don't have this problem at all. Once I get my new AEBS, I will switch to WPA at home. I wonder if this problem will occur at home then or not. I suspect the dot1x may be the culprit.

    I never had this problem on my Powerbook though.
     
  10. rezonat0r macrumors 6502

    Joined:
    Nov 2, 2007
    #10
    Try dropping WEP and see if the connection problems stop. If so, consider using WPA instead, as WEP is fully cracked as far as I know, and is barely better than no encryption at all.
     
  11. Kobi11 macrumors newbie

    Joined:
    Feb 1, 2008
    #11
    Me 2

    Hey i have the exact same promblem with my Macbook and router.. since the Airport Update it hasn't happened but it's quite annoying
     
  12. korpanopoly thread starter macrumors newbie

    Joined:
    Mar 4, 2008
    #12
    Thank you all very much for the replies.

    I have to admit - a majority of the discussion here is far to advanced for me to comprehend fully.

    All I know is that everything was working brilliantly up until this afternoon.

    Now, everytime I wake the computer up from the sleep mode or everytime I restart the computer I have to reconnect to the friggen Internet -it's seriously driving me nuts.

    Last question - I know I am being a pain in the butt here - what should me next step be to remedy this problem - aside from throw the computer and router off my balcony?
    :)
     
  13. taylorwilsdon macrumors 68000

    taylorwilsdon

    Joined:
    Nov 16, 2006
    Location:
    Bay Area
    #13
    I had that problem with my Santa Rosa model so I sold it and bought a Penryn.

    The conflict was between a Linksys Wireless-N router and a MBP with Leopard. Its a well documented issue and Apple refuses to fix it.
     
  14. slm macrumors newbie

    Joined:
    Oct 25, 2007
    #14
    have the same issue when waking up my macbook pro - but figured I just have to wait for like a minute and it's all up and running again. give it some time dude - look at you - how much time you need to do anything when you just woke up :)
     
  15. Wingnut330 macrumors 6502a

    Joined:
    Jan 16, 2008
    Location:
    Central Ohio - USA
    #15
    Mine is doing the exact same thing. It's very frustrating. I can wake my MBA and it connects almost instantly, but my MBP can take up to 5 minutes. I'm using a brand new (and updated) Time Capsule that works fine with with my MBA and my 2 other windows machines. It has to be related to the MBP. It's a new penryn that I just bought yesterday at an Apple Store.

    All the love I hear for these MBP's - I don't get it. Mine has trouble reconnecting to the network and has the yellow screen issue. I'm very disappointed thus far...
     
  16. aaron.lee2006 macrumors 65816

    aaron.lee2006

    Joined:
    Feb 23, 2006
    Location:
    Ontario, Canada
    #16
    Had the same problem. Set your router to broadcast G only or G/B Mixed. Even though I don't have N anymore, it works and fast until Apple fixes the problem.
     
  17. ColoradoCollins macrumors newbie

    Joined:
    Nov 5, 2008
    #17
    Time Capsule / Airport Firmware issue

    Same problem. MBP, losses connection to Time Capsule / Airport every time it goes into sleep mode.

    Time Capsule is fine, Internet modem is fine. The WiFi connection even shows good. The tell tale is the Airport Utility can not connect to the Time Capsule / Airport. If you have Firmware 7.3.2 go back to 7.3
     
  18. fuzwuzreal macrumors newbie

    Joined:
    Jun 28, 2010
    #18
    no networking after sleep on mac pro 8 core original

    It happens every time unless I am using airport with one of the wired ethernet connections. no matter how long the mac stays on, if only wired ethernet is being used, it doesn't wake up. It has been like this with all versions of the OS since b4 leopard and including leopard & snow leopard.
     

Share This Page