MBP MA601LL only powers up when magsafe plugged in

Discussion in 'MacBook Pro' started by jattaie, Apr 13, 2012.

  1. jattaie macrumors newbie

    Joined:
    Apr 13, 2012
    #1
    Hi folks,
    This 2006 MBP 2.16 Core Duo with 2GB RAM running SL with all updates will not turn on with a fully charged battery; it will only turn on when the magsafe adapter is plugged in.
    I've done the SMC reset but no joy.
    Any advice would be appreciated.
     
  2. vlug macrumors 6502

    Joined:
    Jul 18, 2009
    #2
    You're not using it in Clamshell mode attached to a separate display are you?
     
  3. bozz2006 macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #3
    Dead battery? Are you still on the original battery? That's 6 years; a long time in terms of batteries.
     
  4. No1nfoProvided macrumors 6502

    Joined:
    Dec 1, 2009
    #4
    I would definitely check battery health. It might not even hold enough of a charge to run the computer anymore if it really is 6 years old. I have the same exact computer and I'm on my third battery.
     
  5. jattaie thread starter macrumors newbie

    Joined:
    Apr 13, 2012
    #5
    UPDATE: MBP MA601LL only powers up when magsafe plugged in

    Thanks to everyone who replied so far.

    vlug: I am not using it in clamshell mode.

    Bozz2006: it's a new battery. Has a cycle count of 13. Charges fine, discharges slowly like a new battery should.

    No1nfoProvided: It's the third battery on this machine too.

    Every once in a while, it will power up on battery power alone after repeated pressing of the power button, but not usually.
    If I plug in the AC adapter, it powers up and if I immediately remove the adapter, it continues to boot normally. It seems like maybe the new battery isn't supplying enough juice to boot it up.

    I've swapped RAM and had the same result. I've tested known good RAM individually and in pairs and tested each slot and it hasn't made a difference.

    I have to admit, I get off of a challenge and I'm looking forward to figuring it out with the community's help.

    Thanks everybody
     
  6. /user/me macrumors 6502

    Joined:
    Feb 28, 2011
    #6
    Have you tried an SMC reset? The SMC handles everything relating to battery charging, power ect.
     
  7. declandio macrumors 6502

    Joined:
    Apr 3, 2009
    Location:
    London, UK
    #7
    I had a similar problem on the same laptop recently. All of a sudden the battery wouldn't charge and if the maglock was removed, the laptop would die even if the battery had some charge left. Prior to this, the battery was only about a year old, held very good charge and performed well.

    At first I wouldn't believe that it was the battery. I thought it was either the logic board (expensive) or this http://www.ifixit.com/MacBook-Parts/MacBook-Pro-15-Inch-Model-A1211-Left-I-O-Board/IF185-060

    I tried a different battery at an Apple store and everything was fine again. So I bought a new and haven't had problems since.

    I don't know why, but the faulty battery just all of a sudden 'broke' with no notice / symptoms at all.

    (I used the laptop with the battery installed & maglock connected for a few weeks while trying to figure out what was wrong... the battery started to swell and eventually ruptured so beware of that....)
     

Share This Page