MBP mid 2009 - Can't get OWC SSD to work

Discussion in 'MacBook Pro' started by CraigWatkinson, Dec 5, 2011.

  1. CraigWatkinson macrumors newbie

    Joined:
    Dec 5, 2011
    #1
    Hello,

    I have a mid 2009 MBP (5,5) and a shiny new OWC 480GB SSD drive. In a nutshell, I can not get this to work at all. I am trying to install a fresh copy of Lion onto it, but it keeps failing, and I'm running out of ideas.

    The facts:

    - MBP 5,5 13" mid 2009
    - SMC version 1.47f2 (1.5 update won't install as incompatible)
    - EFI firmware v1.7 - MBP55.00AC.B03 - this is the latest listed on Apple support website for my machine
    - SSD = OWC Mercury extreme pro 3G
    - SSD firmware 361A13F0
    - SSD drive has a single GUID partition - formatted ok
    - Disk utility verify shows no problems
    - I have had the SSD drive replaced - first one had exactly the same problems
    - I am installing from a USB key that has been tested OK elsewhere
    - I tried a second USB key created by a different person
    - Install starts ok, copies all the files ok, but during actual install bombs out halfway through. I get a screen saying there has been a failure - no other info.
    - With first SSD I booted from original HDD (in a USB caddy) and tried to restore existing Lion install using disk utility - failed after an hour or so due to "input/output errors"
    - I've cleared PVRAM and tried again
    - I've reformatted and tried again
    - Somebody else has tried (in case it was me!)

    I'm struggling to think of what else to try. Anybody had similar issues, or got any helpful suggestions.

    Many thanks
    Craig
     
  2. tahoeroscoe macrumors regular

    tahoeroscoe

    Joined:
    Apr 25, 2009
    Location:
    California
    #2
    Have you tried installing a clean copy of lion on the SSD? With the old HDD completely removed?

    I'm thinking the errors you are seeing are due to the USB caddy.
     
  3. CraigWatkinson thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #3
    Hello

    yes, the majority of the time, I have only the SSD drive in the machine, directly connected to the SATA interface, and then I am trying to install Lion from a USB stick.

    The machine boots ok from the USB stick, correctly copies all the installation files to the SSD, the machine then automatically reboots, boots from the SSD, and then attempts to install the OS. This is the screen with the BIG 'X'! The failure happens about halfway through this part of the process.

    My attempts to boot from the old HDD in a USB caddy were to try to discount the possibility that there is a problem with the USB device or to use the restore method to replicate my existing installation.

    I haven't tried booting and installing from DVD, but this seems to be clutching at straws a little!

    Thanks Craig
     
  4. GermanyChris macrumors 601

    GermanyChris

    Joined:
    Jul 3, 2011
    Location:
    Here
    #4
    Why don't you just clone the old drive onto the SSD?

    I think the installer is the goat rope..
     
  5. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #5
    Are you using the apple USB stick or one that you or a friend created for you. Aside from possible piracy discussions (which would close this thread), you should try to load Snow Leopard and then purchase Lion through MAS, or buy the apple USB stick if you had not.

    Your posts imply that you are trying to install Lion by way of a home grown USB stick
     
  6. CraigWatkinson thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #6
    Hello,

    thanks for the replies.

    @Chris - I have tried that. I put the original HDD into a USB caddy and tried using disk utility to "restore" the original partition. This failed after an hour or so

    @Maflynn - Yes I am, however there are no piracy issues. I have purchased Lion and I have Lion running on the original HDD correctly. Originally when I installed the SSD I created a USB stick with the recovery partition that you get with Lion. I then downloaded Lion again (twice) only for it to fail both times. By this time, I was fed up of waiting for the download so pulled the installESD.dmg file from the SSD and created a boot stick from that. This was downloaded through my own iTunes account.

    I did try using a USB sick created by a friend, but only to check whether it was my stick at fault. I got the same failure, so I assume the USB

    The weird thing is that the drive seems fine when initially copying the files on/off initially, but then fails later in the installation.

    I will try installing Snow Leopard again. That's a good idea, plus that will rule out a USB issue.

    Thanks
    Craig
     
  7. GermanyChris macrumors 601

    GermanyChris

    Joined:
    Jul 3, 2011
    Location:
    Here
    #7
    Use Carbon Copy Cloner..

    Take anything apple out of the system..

    though the idea of forcing an install makes me uncomfortable..

    I'd give OWC their expensive drive back and find a different one
     
  8. CraigWatkinson thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #8
    Yes it is starting to feel a bit like that. Assuming I do eventually get the OS installed, I'm not sure how much faith I'm going to have in it moving forward.

    Waiting for a call back from OWC's tech support guys. I'll see what they say.

    Cheers Craig
     
  9. CraigWatkinson thread starter macrumors newbie

    Joined:
    Dec 5, 2011
    #9
    UPDATE:

    So this doesn't make a lot of sense, but here is my experience. Iy may be useful to others in the future ...

    - Alll previous attempts to install Lion directly - Failed
    - Install Snow Leopard from DVD - Worked OK
    - Upgrade to Lion from App store - Worked OK
    - Rebooted Lion into recovery partition and performed clean install - Failed
    - Retried Lion install - Worked OK

    ?!?! I can't explain the reasons for this, but everything seems ok for now. If others have similar issues installing Lion, then I suggest following the upgrade route. Installing from legitimate Apple USB sticks may be different, but I wasn't prepared to pay £55 for a copy of something I have already bought through the App store.

    Thanks for people's assistance and advice!
    Craig
     

Share This Page