MBP Mid 2010 13" Battery "(Not Charging)"

Discussion in 'MacBook Pro' started by Bammeh, Nov 9, 2012.

  1. Bammeh macrumors member

    Joined:
    Nov 19, 2010
    #1
    I have a mid-2010 Macbook Pro 13" with a problem.
    The battery says "Not Charging".

    I know it is not a problem with the battery because it has only been through 1050 Cycle and the computer says "Condition: Normal"!

    I am thinking it may be the DC-In Port.
    Could it be a logic board problem?

    If I put the battery in another computer, it charges just fine. So, Im thinking maybe it is a hardware problem.

    Resetting the PRAM and SMC did not work.

    The adapter also stays green, and I know it is not the adapter, I have tried 3 different ones and they all work on other computers.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    PRAM/NVRAM has nothing to do with battery/power/charging issues. Resetting it will not help. Only resetting the SMC addresses such issues.
    If the battery works in another computer, see the link for troubleshooting MagSafe adapters at the bottom of the CHARGING section of the following link. If both the battery and the adapter are working, that pretty much leaves the charging port or the logic board as the culprit.

    The link below should answer most, if not all, of your battery/charging questions. If you haven't already done so, I highly recommend you take the time to read it.
     
  3. Bammeh thread starter macrumors member

    Joined:
    Nov 19, 2010
    #3
    Alright, I'll give that a read.
    It may be the logic board. nothing else is wrong with the computer. It just won't charge.
     

Share This Page