Resolved MBP Mid 2012 not booting from HDD and external USB

Discussion in 'MacBook Pro' started by tweak25, Jan 4, 2017.

  1. tweak25, Jan 4, 2017
    Last edited: Jan 4, 2017

    tweak25 macrumors member

    Joined:
    Jan 12, 2014
    #1
    Hi everyone!

    I've run into a bizarre issue with my 13" cMBP.

    From one day to the next, it stopped booting up and will only show a folder with a question mark.

    My first thought was that my (aftermarket) SSD had failed, so I swapped it out for an old HDD. However, after trying to boot with this disc installed it showed the same behavior. I then plugged in the SSD via a SATA to USB cable but the disc wouldn't show up in either the boot menu or disk utility when using internet recovery.

    I've tried connecting the SSD to an old Laptop running Lubuntu but it won't mount there either.

    I haven't tried hooking up the HDD that's currently inside my MBP to the external SATA/USB cable yet, but will when I get the time.

    However, what are the chances of the SSD and internal SATA cable failing at the same time? I've reset the PRAM, but that did not change anything.

    Sorry for the slightly convoluted tale, would be glad for any suggestions or ideas, as being without my laptop and data is really less than ideal.

    Thanks !
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    13"? They have documented issues with the SATA cable failing. There's actually a silent repair program for them with Apple, so you can probably get it sorted for free if you have a store near you. It sounds like that might be the culprit.

    I know you took out the SSD and put it in a different computer but I don't think it's the SSD. :)
     
  3. tweak25 thread starter macrumors member

    Joined:
    Jan 12, 2014
    #3
    Yes, it's a 13", I'll add it to the OP.

    I've heard of the SATA cable failing in these models. although there doesn't seem to be an official repair program for it, it may be worth asking Apple about.

    Shouldn't my SSD still show up when trying to boot from USB though, even if the SATA cable is shot?
     
  4. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #4
    I think you'll need to try out the HDD in the USB enclosure or try to mount the SSD on another Mac. Being unable to mount the SSD in Lubuntu may be due to several issues unless you've been able to mount an HFS+ file system with the same enclosure and the same characteristics (journaled HFS+ or Core Storage may be an issue) on your laptop before.

    As keysofanxiety mentioned, there does seem to be a silent repair program - another poster in another post mentioned that they were able to get their cable replaced by Apple. If you buy a cable from a place like ifixit, it costs $45. You can buy it cheaper, but is it going to be of comparable quality? May as well get Apple to replace it.
     
  5. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    There's a repair program for it, it's just not advertised. :)

    Possibly the SSD should still show up, especially if you were using a Linux distro as it has HFS+ compatibility, unlike Windows. So it should at least see it. Did it show up when running lsblk in Terminal, or it just didn't mount? Either way I'm pretty confident the SSD's okay as your old HDD in the same Mac exhibits identical symptoms. Plus SSDs are very reliable.
     
  6. tweak25 thread starter macrumors member

    Joined:
    Jan 12, 2014
    #6
    For whatever reason, I am not able to get the SSD to show up on my Linux machine, nor when holding down the option key when starting my Mac or when in disk utility using the OSX recovery utilities I still feel I should be able to boot into El Cap having connected the drive via USB though...

    Either way, it still seems likely there is something wrong with the internal SATA cable, so I will by contacting Apple about that.

    Thanks for the help so far.
     
  7. tweak25 thread starter macrumors member

    Joined:
    Jan 12, 2014
    #7
    Okay, I have now confirmed that the main issue lies with the internal SATA cable. Using my old HDD with Mavericks worked when connected via USB. I will be talking to Apple about getting it replaced.

    Does anyone know what the problem with my Mac not seeing the SSD when using disk utility in recovery mode could be? Could it be the SATA to USB cable not playing nice with it? (Seeing as it doesn't get recognized in Linux either) Conventional hard drives work fine.

    Thanks for all your help!
     
  8. AtheistP3ace macrumors 6502a

    AtheistP3ace

    Joined:
    Sep 17, 2014
    Location:
    Philly
    #8
    This exact same thing happened to me too even down to the steps I took trying to figure it out. Which is what prompted me to buy the new touch bar pro. Genius Bar said they could send it off to get fixed but all data would be lost and cost 1500. I figured that was half of a maxed out 2016 (without maxing hard drive). Loving new laptop. No issues for me.

    I just dropped off the SSD at a data recovery place today to see if I can salvage any data. I stupidly never setup time machine. For sure doing it with new one but lost a lot of work too. And some personal projects.
     
  9. halfbad macrumors member

    Joined:
    Apr 20, 2014
    #9
    There is a chance it's the logic board as well., it causes issues like not recognizing the drive, I had the same issue with my 2012 15" fortunately there was an out of warranty program and apple replaced it for me. I had the same symptoms, I could boot from an external drive, but once the new internal drive was installed it would eventually happen again.

    The logic board issues are intermittent and may come and go. you can take it to an apple store and they can run a 10 minute test to tell you what's up if you like. I would recommend that because I thought it was everything else except that logic board since it would work sometimes, might want to rule that out before spending any money on it.
     
  10. tweak25 thread starter macrumors member

    Joined:
    Jan 12, 2014
    #10
    I might be answering my own question here, but I have a suspicion that the USB port might simply not be able to supply enough power to my SSD as it is rated for 1.6 amperes, something I didn't even think to check
    --- Post Merged, Jan 5, 2017 ---
    I will bear that in mind, thanks, although a logic board fault would really be a kick in the teeth
     
  11. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #11
    With mine, just last week, the Apple Store said it was likely the "flex cable" (their words, same meaning as what keysofanxiety said), which was a known issue and would be covered even out of warranty. Their diagnostic tool started beachballing, at which point the Genius said, "Normally, when this happens with a 2012, it's the cable that's gone bad," which is when she started explaining the flex cable issue to me.

    In my case, they also said later that the HD was failing (which my Disk Utility had reported a few months ago) and required replacement. Because my last Time Machine backup was less than two days old, I had them replace it, and I was up and running by the next morning.
     
  12. tweak25 thread starter macrumors member

    Joined:
    Jan 12, 2014
    #12
    Well, Apple is replacing the cable free of charge. I left it at the Apple Store with the original spinning HDD in it (which I know for a fact works), as I couldn't confirm whether my SSD is dead or not. I tried several adapters but it just won't connect externally.
     
  13. tweak25 thread starter macrumors member

    Joined:
    Jan 12, 2014
    #13
    Got the computer back from Apple, popped in the SSD and it started booting up as normal after a few seconds.

    I don't understand why the SSD refused to work externally but I'm glad to be back up and running!

    Thanks for the input guys!
     

Share This Page