MBP mid-2012 OptiBay HDD spins down after 30 secs

Discussion in 'MacBook Pro' started by xristy, Aug 16, 2013.

  1. xristy macrumors member

    xristy

    Joined:
    Jul 31, 2007
    #1
    Hello,

    I have a mid-2012 15" MBP running 10.8.4. I have a Crucial 512 M4 SSD in the primary bay and a WD10JPVT in the Optibay (via OWC data doubler).

    I have system, apps and so forth on the SSD and user data on the HDD.

    The issue that I have is that when the HDD spins up to access some data (read or write) then there is a short stall while the drive spins up - that part is to be expected; however, unless the HDD is accessed again within 30 seconds (I timed this numerous times and it is 30 seconds as near as I am able to measure) then it spins down. So if I'm doing "normal" interaction with the system then the drive is spinning down and spinning up with a stall and down again and so on. I'm usually just not so fast that I switch among folders or spot a new file to open or whatever within the 30 second window.

    I've tried:

    pmset -a disksleep 0

    and

    pmset -a disksleep 10 (actually the default)

    and these appear to have no effect. The HDD still spins down after 30 seconds after the last access.

    I've tried two different HDDs with the same behavior. I've also tried the Fusion configuration but that was a lose since the HDD then is spinning up and down all the time for whatever reason related to Fusion placement of files; hence, I'm using the 2 separate drive configuration for now.

    I also have an early-2011 15" MBP running 10.8.4 with a Fusion configuration of the same SSD and HDD and OWC data doubler and have no such issues on that system.

    I'd really appreciate any ideas about how to "fix" the issue or why it's happening.
     
  2. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #2
    System Pref's > Energy Saver, uncheck put hard disks to sleep.
     
  3. xristy thread starter macrumors member

    xristy

    Joined:
    Jul 31, 2007
    #3
    I guess I wasn't clear. I have explicitly:

    pmset -a disksleep 0

    which is exactly what:

    System Pref's > Energy Saver, uncheck put hard disks to sleep.

    does.

    In any event it doesn't work / help.

    Thanks
     

Share This Page