MBP not booting, Timemachine doesn't fix it, refuses password

Discussion in 'Mac Basics and Help' started by rinus8, Jun 14, 2018.

  1. rinus8 macrumors newbie

    rinus8

    Joined:
    Jun 14, 2018
    #1
    Hi all,

    Earlier today my 2012 Macbook pro (750GB HDD) was working fine but suddenly got extremely slow, so I decided to do a reboot.
    The reboot didn't succeed, after I filled in my password the apple logo showed up for a while, then I was put back to the password screen again (time after time). Tried rebooting again a couple of times, then also the 'prohibited' sing started to appear after the login screen, together with the apple logo, but still was stuck.

    I read that it may be due to OS disk not being found, so I started up in recovery mode (cmd+r), and using disk utility I found that the HDD of 749.3 GB only had 32mb free space left (I only have ~350 GB of data, so something is wrong there). I did scan/repair a couple of times, reboot again, but still stuck after login screen. Now also the '?-folder' sign started to appear.
    Next, I got my external HDD to make a Timemachine reset via Disk Utility in recovery mode, took a couple of hours but it finished. However, still same story when logging in, and still the HDD is completely full (strange after resetting an old Timemachine backup?)

    Then I tried to erase the disk before giving the Timemachine backup another go, again via Disk Utility in recovery mode. There are 4 disks shown (and a dvd drive). The upper one is called Macintosh HD, and is not eraseable, the second one with the same name was able to be erased, so I did. Below that it shows the boot disk partitions I think? Just a few GB which can't be erased?
    But the strange thing is, after the erase of Macintosh HD (2nd disk) and selecting the Timemachine backup via Disk Utility in recovery mode, it refuses to accept my password! Which I used 2 hours ago for the first Timemachine attempt...

    Now I'm starting to get a bit worried, is my Timemachine (also) corrupted? Is there any way to fix this situation?
    Currently I'm waiting for a recovery mode startup, hopefully it will accept my timemachine PW this time..
    Sorry for the long story!
    Thx in advance
    --- Post Merged, Jun 14, 2018 ---
    Strange, after the last recovery mode boot it did accept my TM password. However, the internal HDD does not show up anymore.. Not in the Disk Utility tool, and not in the TM restore tool (when searching for destination disks to put the TM restore, it does not find any disks).
    Disk Utility does still show the Disk0/Mac OS X base system disks..
    Is there any way to restore the TM backup?
     
  2. chscag macrumors 68020

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    You need a new hard drive. That one has failed. After installing the new hard drive and macOS, you can try restoring all your data from Time Machine.
     
  3. Audit13 macrumors 68030

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
  4. rinus8 thread starter macrumors newbie

    rinus8

    Joined:
    Jun 14, 2018
    #4
    Ok, not surprising after 6 years of daily work-related use. It died quite quickly then, within half a day it went from nothing wrong to this.
    I found it also strange that the erasing of the disk only took 5 minutes or so, to erase a 750GB disk..
    --- Post Merged, Jun 14, 2018 ---
    Thx for the suggestion, I will look into this :)
     
  5. Funsize93 macrumors member

    Funsize93

    Joined:
    May 23, 2018
    Location:
    Australia
    #5
    We need to isolate a software or a hardware issue. I would perform an SMC reset and then load internet recovery (option+command+R immediately after booting) > Disk utility > Click on the view menu and choose "Show all devices". If you dont see the internal HD: i would service the mac. If you see the HD: i would erase and reformat the top level HD in the internal section (format to macOS extended journaled) and then run a first aid. If passes i would then reinstall the OS and setup the computer as new and test. If everything is working then i would use migration assistant to bring your data back. If however anytime during those steps you come to a roadblock or first aid fails you are looking at a hardware issue.
     
  6. rinus8 thread starter macrumors newbie

    rinus8

    Joined:
    Jun 14, 2018
    #6
    Thanks for the detailed advice, I will for sure give this a try!
    I also tried to do a fresh OS X install earlier (via Disk Utility in recovery mode) but this could not be done as I got the notification: 'The newest version of OS X is already installed'. Sure, but I want to re-install it, not update :)
    Btw, in my case cmd+r always gives me Internet recovery mode
     
  7. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    It could the internal SATA ribbon cable (they were a point of failure on 2012 MBP's).

    It could be the internal hard drive (hardware problem).

    It could be a software problem with the OS.

    I know this next bit of advice doesn't help you right now, but this is where having an EXTERNAL BOOTABLE CLONED BACKUP is 100x superior to having a TM backup. You can connect the backup and boot boot right back to the finder (assuming the copy of the OS on the backup is good).

    It's -possible- that the internal drive got clogged up with TM "local backups". I can't see why anyone would have this feature enabled, even if they use TM.

    Suggestion:
    Do you have a USB flashdrive around that is 16gb or greater?
    If so, try this:
    - Boot to internet recovery
    - Insert the flashdrive
    - Open Disk Utility and erase the flashdrive to Mac OS extended with journaling enabled (GUID partition format)
    - Now open the OS installer. "Aim it" at the flashdrive (not the internal drive)
    - See if the installer will install a copy of the OS onto the flashdrive
    - If it works, go through setup on the flashdrive, create an account, give it a name, password, etc.

    WHY you want to do this:
    You now have an EXTERNAL boot source, that will take you to the finder with a logged-in account.
    If you can't boot "internally", you can connect the flashdrive and hopefully get booted that way.
    Boot trick (you probably already know this): Power off, insert flashdrive, press power on button, IMMEDIATELY hold down the option key until the startup manager appears. Then select the flashdrive with the pointer and hit return.

    This won't "solve" problems with the internal drive.
    But by getting the Mac booted to the finder, it makes it much easier to "work on it".
     
  8. Funsize93 macrumors member

    Funsize93

    Joined:
    May 23, 2018
    Location:
    Australia
    #8
    Hmm, I have come across this error message before (seems like the Mac is still holding onto an old installation file) The workaround which worked for me was: Boot to internet recovery > erase the top level internal HD (may need to view "show all devices" > shutdown the mac > NVRAM reset > boot to internet recovery again and erase the top level HD one more time. After that try reinstalling the OS fresh again and setup the mac as new (without a backup yet) If everything looks fine and is working great i would then use migration assistant to bring your data back. (May need to update to the latest OS first)
     
  9. rinus8 thread starter macrumors newbie

    rinus8

    Joined:
    Jun 14, 2018
    #9
    OK it finally booted and it's working smoothly! So I would guess the HDD isn't (fully?) dead, and maybe it was a software issue after all.

    This is what was done:
    When I started it up yesterday in recovery mode, I noticed that the upper HDD partition was fully erased after all (It wasn't like that right after the 'erase'), with 749GB available. So I tried to put a fresh install of OS X on that drive, and it fully continued.
    After the install I tried a regular boot, didn't work as it still had the previous partition active as boot disk apparently, so again via recovery mode:

    [​IMG]

    [​IMG]

    You can see there's now 6gb on it for the OS.
    Images below show details on the other partition with the old OS. Via the recovery software I can't do anything with it, does it look OK in general?

    [​IMG]

    [​IMG]

    [​IMG]

    After checking the disks, I selected the other disk to use as boot disk:

    [​IMG]

    And now I'm in! Running on OS X 10.8.5, and it works just fine.

    What would be the best way to proceed now?
    I have my TM external HDD with my data backup standing by, but first I might want to check the health of my Mac's internal HDD? Or do I need to also erase the partition with the 'old', non-booting OS?
    Before transferring the TM data, as already mentioned above, I should update the installed OS. But it sounds reasonable to first get rid of the other partition with the faulty OS, and get everything worked out on that side.
    What's best to do?
    Thanks for all the help so far, I'm glad it's running again :)
     
  10. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #10
    In your pics above...

    - 750.16 GB Apple HDD -- this represents the physical hard drive in the MacBook

    - Macintosh HD -- this is your "main partition" (on which the OS, your accounts, apps, all reside)

    - HL-DT-ST DVDRW GSR1N -- this looks to be an internal DVD drive ??

    - disk1 -- I'm going to guess that this is the "recovery partition"

    - Mac OS X Base System -- this is the copy of the OS on the recovery partition that "gets it booted" (when you choose to boot from the recovery partition)
    YOU DO NOT WANT TO ERASE THIS. LEAVE IT THERE.

    If the computer is booting up this way, and you can log in and get to the finder (this is VERY important, that you can LOG IN and GET TO THE FINDER), then you should be able to "migrate your data" over from your backup.

    How I'd do it:
    1. Power down, all the way off
    2. Connect the TM backup drive
    3. Power up, get to the finder
    4. Open migration assistant (in the utilities folder)
    5. Migration Assistant takes a moment to get going, will quit other apps, and want your password.
    6. "Aim" Migration Assistant "at" your TM backup drive
    7. MA will scan the drive to see what's there, then present you with migration options (applications, accounts, settings, data)
    8. I would choose to migrate everything (UNLESS you suspect it was some kind of software that you installed that caused the slowdown -- then a whole different migration scenario is needed).
    9. MA will take some time to "do its thing", and you can ignore the messages about "xxx amount of time left" -- highly inaccurate..
    10. When done, I suggest you power down, disconnect the backup, reboot, get to the finder, then log into your original account (the one on the TM backup).
    11. Does this do it for you?

    I didn't re-read the entire thread, but if this is a 2012-design NON-retina MacBook Pro, the problem with drive "slowdowns" COULD BE the internal SATA ribbon cable -- easily and cheaply replaced as mentioned above.
     
  11. rinus8, Jun 24, 2018
    Last edited: Jun 24, 2018

    rinus8 thread starter macrumors newbie

    rinus8

    Joined:
    Jun 14, 2018
    #11
    3x yes

    I'm not sure about that, since this Disk1 and the Mac OS X Base System where there already before I did the recovery install of the fresh OS. This fresh OS is now on the main Macintosh HD, the partition above. I think I now have OS 2x installed... So, when I boot in the normal way, it uses the faulty OS on the Disk1 partition, but when I boot the fresh OS from the 750GB HDD disk which I can select (see last image) then I can boot into finder, and everything works an usual.

    So my question would be: I suspect this partition with this OS is faulty, since when booting with this one I get the 'prohibitory sign', so can I erase/reinstall it?

    This sounds good, only issue I can think of is that in this way, when TM puts the data back on the disk, it erases my only working OS install and I'm still stuck with the wrong OS on the Disk1 partition... But I'm not sure if it works this way?

    Edit: When checking Disk Utility via finder running the fresh OS, the Disk1 partition is not shown (it's already set at 'show all'). Is it gone then?
    Edit2: Yes it's a Mid-2012 13" MBP, 2.9 GHz i7, 8GB DDR3 and 750GB HDD
    [​IMG]
     
  12. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #12
    "This sounds good, only issue I can think of is that in this way, when TM puts the data back on the disk, it erases my only working OS install and I'm still stuck with the wrong OS on the Disk1 partition... But I'm not sure if it works this way?"

    You DID NOT READ the instructions I wrote in reply #10 above.

    YOU DO NOT NEED TO USE TIME MACHINE TO "RESTORE" YOUR DATA.
    (shouting intentional)
    Use MIGRATION ASSISTANT instead.

    Go back to post 10.
    PRINT OUT these instructions.
    Then... follow them.

    My prediction is that -- if you do -- you will have "success".
     
  13. rinus8 thread starter macrumors newbie

    rinus8

    Joined:
    Jun 14, 2018
    #13
    Just replaced the SATA cable, it's booting smoothly now......
    After the first boot (which took a few tries) I was in finder and thought all was OK (as described above). Then I had to do a restart to allow some software updates to finish, when the booting issues started all over again. :(
    So, was trying for a few hours to get it to boot, got sick of it, ordered a cable, done.
    It all could have been finished after the 3rd post :) now going to put data back
     

Share This Page