MBP (Not Charging) & Mag Safe odd behavior

Discussion in 'MacBook Pro' started by purpleinnej, Oct 3, 2010.

  1. purpleinnej macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #1
    My new-ish MBP is still under warranty and with the issues I've had I'm wondering if I don't need to get AppleCare. Hubby is a PC guy and as much as I love my mac, his constant, "My computer doesn't have any problems" is starting to ring true.

    Issue #1--CD stuck in optical drive. New drive installed; good.

    Issue #2--Battery in (Not Charging) status. Called Apple, got a new power adapter sent to me. While waiting, I purchased a new power adapter. The one I purchased worked fine for the week wait and I returned it when I got the one from Apple. The one from Apple has worked for about a week but now I'm back to same old behavior from it.

    Symptoms: Battery status: (Not Charging) but power adapter supplies enough power to run the MBP (just not to charge it). When I unplug the magsafe end, it stays lit green unless I unplug it from the outlet as well.

    Troubleshooting: different outlet, different adapter (cord vs. wall adapter)

    Complicating factors/possible causes:
    --My baby put the magsafe end in his mouth, so it got wet. I didn't know about that until I said something to my husband about it acting up and he told me he saw the baby with it earlier today (hours ago)
    --I live in Japan on a military base so "take it to a genius bar" isn't an option for me. If Apple gets involved (which has happened twice already) it means I give a delivery service my laptop, they get it to Apple until it's fixed, then the delivery service returns it to me (about a week turn around) OR I wait for said delivery service to bring me (another) power adapter and I trade them my bad one for a good one.
     
  2. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #3
    No it didn't answer any of my questions. Or at least not that I saw. I've already read almost all of that info.
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    So I guess that means you already reset your SMC, with no effect. If that's the case, it sounds like you still have a hardware problem.
     
  4. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #5
    Yep. Multiple times actually. Sorry forgot to include that in the troubleshooting section.
     
  5. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #6
    Make sure there is no debris on any of the pins and that no dirt is preventing the magsafe from seating itself flush with socket.
     
  6. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #7
    Did that first thing. I have another call into Apple and they're coming in two days to take my computer to their center to see if they can fix it, since it appears at this point it's not the power adapter, but the computer.
     

Share This Page