MBP not recognizing headphone/speaker?

Discussion in 'MacBook Pro' started by yusukeaoki, Feb 2, 2012.

  1. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #1
    Hi guys.

    So I have noticed this since purchase of my MBP (Feb 2011) and it annoyed me so I want a solution.

    This doesn't always happen. Only sometimes.
    What it does is that when I plug my headphone, I mean any headphone, it wont recognize it so it plays through the speakers.
    This doesnt get fixed until restarting the MBP (which is really annoying).

    I had times where it didnt recognize my speakers, or it thought it had headphones in. After I unplugged my headphone, the red laser in the output was still on and thought it still had my headphone in.
    Again, I had to restart my mac.

    I tried system preference but the computer thinks it has headphones in or it thinks it doesnt have anything in so it didn't really matter. Couldn't change anything.

    Again, it only happens like 5 times a month. I dont know why it does that but its annoying to restart a computer everytime when it can't recognize the I/O.

    I never really had a microphone plugged in (since it already has internal one) so I dont know if it does the same thing like my headphones.

    Does anyone have similar problems? Is there a solution?
    Can it be a defect or these things where Apple can't get it to fixed?
     
  2. pscraig macrumors member

    Joined:
    Apr 9, 2008
    #2
    I'd take it to an Apple genius bar and let them look at it while it's still under warranty. That's not normal behavior.
     
  3. dacoolest macrumors regular

    Joined:
    Nov 11, 2011
    #3
    I have the same problem. I always have to restart when this is happening.
     
  4. yusukeaoki thread starter macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #4
    I guess its a possible defect?
    Or maybe just a glitch?
     
  5. bdodds1985 macrumors 6502a

    bdodds1985

    Joined:
    Jul 18, 2011
    Location:
    Tartarus
    #5
    I've had to go into system preferences and change it manually. I found an app called Audio Switcher which goes into your menu bar, allowing you to switch back and forth from external audio devices. I doubt it is a problem with the MBP because I have noticed it too and heard the same thing from a couple other people.
     
  6. yusukeaoki thread starter macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #6
    I guess its a glitch Apple never cared to fix or never found out?
    Hmm its interesting to hear how everyone else is experiencing this too.
    Im trying to fund a pattern when this occurs but so far it seems random.
     
  7. thatoneguy82 macrumors 68000

    thatoneguy82

    Joined:
    Jul 23, 2008
    Location:
    Beach Cities, CA
    #7
    That does sound like a defect that should be brought in to a genius bar. Did this just happen recently or was it like this since you got it? My audio out for headphones work instantly, as soon as I plug it in, the audio diverts to the headphones. When I unplug it, it goes back to the MBP speakers immediately. That's how it should work.
     
  8. yusukeaoki thread starter macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #8
    I dont remember but I think few weeks after purchase (or release date of early 2011). It happens especially on wake. When I plug it in, it doesnt recognize it. I tried hust putting back to sleep and waking it up but still didn't work. The only solution was to restart.
     

Share This Page