mbp on tv cuts out top and bottom

Discussion in 'Mac Basics and Help' started by mbpkid, Oct 30, 2011.

  1. mbpkid macrumors member

    Joined:
    Feb 26, 2011
    #1
    hey i have my mbp set up on my tv but the bottom and top part of screen is cut out. i looked it up and people were saying to enable or disable overscan option but mac took that option out. so now how do i fix this problem? does anyone know how ? my menu on top is cut out and part of the bottom too. if someone knows how to fix this it will be greatly appreciated
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What exact Mac with what exact Mac OS X version with what exact adapter to what exact input do you use on what exact TV?
    Have you already looked into System Preferences > Displays? Have you disabled MIRROR DISPLAYS?

    Have you looked at SwitchResX yet?
     
  3. BarkingGhost macrumors regular

    Joined:
    Oct 18, 2011
    Location:
    Atlanta+35 miles
    #3
    Keep in mind the display (ahem, TV) has ultimate control of how the desktop will eventually be displayed. For instance, my Panasonic plasma has a forced overscan on all inputs except the VGA input that it calls PC. Panasonic just cannot consider computers using any other type of video transport (idiots).

    What you might need is something that can shrink your desktop into a frame video feed much like a picture in a picture frame. That way the frame portion of the video is what is over-scanned. Does SwitchResX do this?

    BTW, my Vizio afford me the option to adjust and even turn off overscan on all video inputs.
     
  4. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #4
    You can adjust the overscan on most newer TVs. I have a 3 year old plasma that I have to get into the factory settings to do it, but it fixed my exact problem that you are describing.

    Look for your tv make and model online and see if there is a fairly easy way to adjust the overscan settings on your tv. Such as just turning overscan off and on.

    Most HD TVs actually have about 5 lines of Overscan set all the way around the edge. You just don't notice until you connect a computer that can't handle the overscan through the graphics card.
     
  5. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    The setting on at least my TV (Panasonic) and several others is "Dot-by-dot" mode--it will be one of the options in the aspect ratio selector, where you choose between widescreen, stretch, crop, etc modes of widescreen-ness.

    Dot-by-dot does exactly what it sounds like--displays the picture exactly as sent. For some utterly bizarre reason, even with a pure-digital, pixel-for-pixel HDMI signal, most if not all TVs default to an overscanned mode where they cut off a bit around the edges, just like with an old school analog TV (which was necessary because of garbage data around the edge of the frame--you can see this when watching most DVDs on a computer).
     

Share This Page