MBP only booting in safe mode

Discussion in 'MacBook Pro' started by Thijs Moonen, Jan 9, 2017.

  1. Thijs Moonen macrumors member

    Joined:
    Aug 22, 2011
    #1
    Hi, and thanks for taking the time to consider helping me out!

    Here are the symptoms:

    • my early 2013, 13" Retina Macbook Pro running Sierra will only boot in safe mode
    • when booted, the comp feels slow (e.g. I can't boot a program from finder because it doesn't find it) and graphics seems chopped. I don't know if this is due to safe mode, or if it part of the core problem

    • BEFORE this happened, my shift-keys (not caps lock key) acted weirdly, sometimes getting stuck in caps, then not functioning at all. They are not held down physically, just to be clear.

    Here's where I get stuck:

    • my guess is/was that there's something wrong with the shift-key and that the comp only boots in safe mode because of it (holding down shift during startup is the command for a safe boot)

    • I want to try a fresh install, but I can't get the MBP to boot from my flash drive with the Sierra installer on it!

    So, do you have any idea what may be the core problem and/or how to proceed? Is the shift-key stuck and therefore overrides the command to boot from an external drive?

    Thanks!
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Run the Apple Hardware Test and see if anything kicks out. Sounds like maybe something has failed on your computer.
     
  3. Thijs Moonen thread starter macrumors member

    Joined:
    Aug 22, 2011
    #3
    Thanks for your reply. This is getting interesting:

    • I tried booting with D held down (AHT/diagnostics) - no result
    • I tried booting with CMD+G held dow - she boots as normal! no recovery mode though; that's strange

    • I tried booting with D held down, on an external, wired keyboard (from a 99 bondi blue iMac!) - no result, the keyboard does function
    • Same for C boot - clean install still not an option

    When I managed the normal boot, everything functioned as normal except the left shift key, which does not capitalize when held down.

    For users with similar issues, this article seems to point to the core of the problem and a few possible workarounds if you don't want to have your whole topcase replaced.

    I'll try a few more things and come back to report.
    --- Post Merged, Jan 9, 2017 ---
    The outcome so far is that until Karabiner will be updated for Sierra so that I can disable the shift-key, I will continue booting with cmd+g
     

Share This Page