MBP only boots plugged in with battery out?!

Discussion in 'MacBook Pro' started by mac-in-kenya, Apr 25, 2010.

  1. mac-in-kenya macrumors newbie

    Joined:
    Apr 25, 2010
    #1
    I have an old mbp (2007 vintage), recently upgraded to snow leopard, and the battery needed replacement. Dutifully bought new battery, installed, charged etc. Then two days ago the computer refused to boot--when I press power button all that happens is I get a notice "Need to reboot--press power button...". Fiddled around, booted once with snow leapord and got it to boot once with the old battery, then it stopped again.
    I did all the things I was supposed to...
    - unplugged power, waited, then re-plugged
    - cleaned out power area
    - tried to reset pram but computer refused
    - reset PMC (forget the initials) but held down power button 5s with power and battery out

    each time I tried to boot and got the same message.

    I just tried booting with the battery out and only electricity plugged into outlet and it worked!! I am backing up now but have no idea why this is happening? Anyone else have a idea how to solve this problem?
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    Sounds like you have another bad battery. Its firmware could possibly be corrupt.

    If you happen to have another similar vintage macBook Pro around, try using the battery in that and see if it has the same problems.

    Also: what does you Kernel panic log say? If you post the contents of the log, it might shed some light on the problem.
     

Share This Page