Resolved MBP only detecting Headphones sometimes

GuitarG20

macrumors 65816
Original poster
Jun 3, 2011
1,020
1
Hi all.

My MBP doesn't detect it when I plug in headphones. However, when I put her to sleep and then plug the headphones in before I wake her back up, she then detects the headphones. If I then remove them, it goes back to speakers like it should. however, it doesn't detect the headphones if I try to plug them in again.

any ideas on what it is and what i should do?
 
Last edited:

Xcallibur

macrumors 6502a
Jul 24, 2011
515
1
Manchester
Maybe there is an option under the audio settings where you can enable the automatic switch of the audio output device. I can't be sure as I do not yet have OSX to use, an idea though.
 

GuitarG20

macrumors 65816
Original poster
Jun 3, 2011
1,020
1
Maybe there is an option under the audio settings where you can enable the automatic switch of the audio output device. I can't be sure as I do not yet have OSX to use, an idea though.
nope, that's not it. there is a place where you tell it what to use as the output, but when I am having problems, the headphone jack doesn't appear as an option.
 

Xcallibur

macrumors 6502a
Jul 24, 2011
515
1
Manchester
nope, that's not it. there is a place where you tell it what to use as the output, but when I am having problems, the headphone jack doesn't appear as an option.
Are you sure the headphone output is enabled then? In Windows, the different audio outputs sometimes get disabled, making them disappear from view and unable to be used. Just another thought.
 
Last edited:

GuitarG20

macrumors 65816
Original poster
Jun 3, 2011
1,020
1
Are you sure the headphone output is enabled then? In Windows, the different audio outputs sometimes get disabled, making them disappear from view and unable to be used. Just another thought.
I'm not sure there is a way to disable them... this is what it looks like when I plug in my headphones (after waking the computer up):

 

Xcallibur

macrumors 6502a
Jul 24, 2011
515
1
Manchester
I'm not sure there is a way to disable them... this is what it looks like when I plug in my headphones (after waking the computer up):

Image
I know its probably not the issue, but have you tried using different headphones? Maybe the headphone connector is a bit duff (doubt it though, as the laptop should still recognise the headphone jack).

You know when you select the "About this mac" button on the top left of the Apple menu-bar and you see varying details of the hardware on your pc, well there should be a section for "Audio", in this section try and see if it lists any devices as disabled. Its just another thought, since I can't try these possible solutions myself :/
 

GuitarG20

macrumors 65816
Original poster
Jun 3, 2011
1,020
1
I know its probably not the issue, but have you tried using different headphones? Maybe the headphone connector is a bit duff (doubt it though, as the laptop should still recognise the headphone jack).

You know when you select the "About this mac" button on the top left of the Apple menu-bar and you see varying details of the hardware on your pc, well there should be a section for "Audio", in this section try and see if it lists any devices as disabled. Its just another thought, since I can't try these possible solutions myself :/
Yes I have tried different headphones. Same problem with all of them.

No, there is no way to disable devices in system report as far as I know.
 

Xcallibur

macrumors 6502a
Jul 24, 2011
515
1
Manchester
Yes I have tried different headphones. Same problem with all of them.

No, there is no way to disable devices in system report as far as I know.
Right, was just wondering if it listed any as disabled, but fair enough, I can't really think of anything else to try without messing around with OSX myself. What did you end up doing?
 

Rampant.A.I.

macrumors 6502a
Sep 25, 2009
579
9
Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

Clear the headphone jack with canned air. There's a sensor in there that detects whether or not a jack is plugged in, and if it gets clogged it won't recognize the jack.

You could also try rapidly plug/unplugging the headphone jack to clear it, but I'm assuming you already have.
 

GuitarG20

macrumors 65816
Original poster
Jun 3, 2011
1,020
1
Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

Clear the headphone jack with canned air. There's a sensor in there that detects whether or not a jack is plugged in, and if it gets clogged it won't recognize the jack.

You could also try rapidly plug/unplugging the headphone jack to clear it, but I'm assuming you already have.
Yes, I already tried the rapid plug/unplug method, but it had no result.

I will try clearing the jack, but I don't know if being clogged could cause it to not recognize headphones inserted while on, but still recognize them if inserted while asleep.
 

Rampant.A.I.

macrumors 6502a
Sep 25, 2009
579
9
I don't know for sure, but I figured I'd throw it out there... My PowerBook sometimes did what you're describing. Drove me nuts. The canned air method seemed to work.
 

GuitarG20

macrumors 65816
Original poster
Jun 3, 2011
1,020
1
Update: SMC reset fixed it for now. should have tried that first-sorry!
 

mertiegirl

macrumors newbie
Apr 4, 2012
1
0
MB Pro Headphones

When I plugged my headphones in this morning on my 13" MB Pro (late 2011), the sound would only come out the speakers of the laptop and not the headphones :( I read a few forums and just tried a few things. I opened Preferences, then Sound. When I clicked on the Output Tab, "Internal Speakers" was listed and it said below "Use Audio Port" for "Sound Output". Then when I clicked the "Input" tab, the internal microphone was listed as the device for sound input and below that, it said "Use Audio Inport" for "Sound Input". Just for the heck of it, I changed the last thing (Use Audio Inport) to "Sound Output". My headphones started working! This really didn't make sense to me, but hey, it worked! I also noted, then, that when I clicked on the Output Tab above, the Device for Sound Output changed to "Headphones" instead of "Internal Speakers". I don't know how this got switched or if this is the "real fix" but like I said, it worked! Hope this helps someone else.:)
 

jonathanrz

macrumors newbie
Jul 28, 2014
1
0
When I plugged my headphones in this morning on my 13" MB Pro (late 2011), the sound would only come out the speakers of the laptop and not the headphones :( I read a few forums and just tried a few things. I opened Preferences, then Sound. When I clicked on the Output Tab, "Internal Speakers" was listed and it said below "Use Audio Port" for "Sound Output". Then when I clicked the "Input" tab, the internal microphone was listed as the device for sound input and below that, it said "Use Audio Inport" for "Sound Input". Just for the heck of it, I changed the last thing (Use Audio Inport) to "Sound Output". My headphones started working! This really didn't make sense to me, but hey, it worked! I also noted, then, that when I clicked on the Output Tab above, the Device for Sound Output changed to "Headphones" instead of "Internal Speakers". I don't know how this got switched or if this is the "real fix" but like I said, it worked! Hope this helps someone else.:)
Helped me, thanks! :)

I believe this is the real solution, the audio port was switched to a input device(something like a microphone or an instrument), the correct solution is to set it to output devices again.

Thanks
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.