MBP Optibay HD won't mount. Please help.

Discussion in 'MacBook Pro' started by yespi, Feb 23, 2012.

  1. yespi macrumors member

    Joined:
    May 28, 2007
    #1
    I recently installed a second HD in my MBP everything worked fine but today the computer wasn't responding so I pushed in the power button till it turned off.

    Now the computer won't mount the HD from the Optibay, I tried repairing it but it won't mount. I get a message " the disk ---- could not be mounted"

    Can anyone please help me.

    Thanks
     
  2. yespi thread starter macrumors member

    Joined:
    May 28, 2007
    #2
    I made a scan with Drive Genius 3 on the hard drive it was working for over 12 hours and found over 600 bad blocks and it wasn't even at 10%.

    Can this be fixed or should I return it since its still in the 30 days I bought it.

    Thanks.
     
  3. shootist macrumors regular

    Joined:
    Dec 8, 2011
    #3
    Did you buy it from Mectech with the hard drive in the caddy?

    If so yes return it.

    But first you could try Re-Seating the drive cable on both the caddy and the motherboard. A bad cable and/or it not making good contact can cause all kinds of hard drive problems.

    Even if re-seating the cable works you made have to re-partition and format or Erase and format the drive. The data may have gotten corrupted with the cable not connected correctly.


    Good Luck.
     
  4. Sirolway macrumors 6502

    Joined:
    Jun 13, 2009
    Location:
    London
    #4
    +1
    Good advice (reseat cable & wipe the disk)
     

Share This Page