MBP/OSX 10.6 doesn't recognise printer

Discussion in 'Mac Basics and Help' started by Philip Howard, May 4, 2010.

  1. Philip Howard macrumors newbie

    Philip Howard

    Joined:
    Jan 20, 2008
    #1
    Hello, I wonder if you can suggest something?

    My MBP currently doesn't recognise the printer I have (HP OfficeJet 6210, which has worked before with this computer). In fact the list of printer models under "add printer" is now empty. So it doesn't detect any printer and I can't suggest any printer for it to detect.

    I tried reinstalling the "printers" part of Snow Leopard but it didn't change anything.

    What would be the best thing to do?

    Thanks!
     
  2. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #2
  3. Philip Howard thread starter macrumors newbie

    Philip Howard

    Joined:
    Jan 20, 2008
    #3
    Actually i did try that. It looked like it was going to help but at the last moment everything was the same again.

    Maybe I could try a complete Snow Leopard re-install?

    Thanks very much for replying!
     
  4. MrCheeto macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #4
    Delete all HP software and remove the printer from Print & Fax.

    Delete every bit of HP software related to your printer. Just go to Finder and Command+F then type HP then Hewlett or Packard.

    With the printer unplugged, go to Print & Fax. Click to highlight the white printer list and then right click and click "Reset printing system..."

    Now plug the printer in. It should be recognized automatically. If not, press the + in the Print & Fax pane and add it.
     
  5. Philip Howard thread starter macrumors newbie

    Philip Howard

    Joined:
    Jan 20, 2008
    #5
    Thanks, you've been *extremely helpful*

    Now the printer is recognised!

    I tried to print a page but the printer is marked as "idle" and the document was not added to the print queue. Is there a trick for this too?

    I'm very grateful!
     
  6. MrCheeto macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #6
    Did you Reset Printing System? If so, I can't think of anything else that could be causing this.

    When I print, my printer is marked as Idle, yet begins to print after about ten-seconds. Are you sure you're selecting the right printer to print to?
     

Share This Page