MBP Overheating when battery being charged

Discussion in 'MacBook Pro' started by neuromage, Jul 30, 2007.

  1. neuromage macrumors newbie

    Joined:
    Jul 30, 2007
    #1
    Hi everyone,

    I just got my MBP some days ago. My first ever Mac!

    Anyway I have a noticed a serious problem. Whenever I plug in the adapter to recharge the battery, my MBP starts to overheat, and the fans kick into overdrive, and it gets really loud. And when I unplug it, the machine gradually cools and the fan slows down. Does anyone have any idea why this is happening? Is this a known issue? There is another thread with the same question, but no real answer. Also, I have been experiencing random crashes too. The grey screen of death. My kernel panic log is different from the ones I've seen posted here:

    Code:
    panic(cpu 0 caller 0x00128DA7): {0} Assertion failed: file "/SourceCache/xnu/xnu-792.22.5/libkern/c++/
    OSObject.cpp", line 267: mem
    
    Backtrace, Format - Frame : Return Address (4 potential args on stack) 
    0x25623bb8 : 0x128d08 (0x3cc0a4 0x25623bdc 0x131de5 0x0) 
    0x25623bf8 : 0x128da7 (0x3cc0cc 0x0 0x3f269c 0x10b) 
    0x25623c28 : 0x3bf03d (0x3f269c 0x10b 0x3d7c44 0x5ee0900) 
    0x25623c48 : 0x97d685 (0x33dc 0x43dada0 0x3e49ce0 0x0) 
    0x25623c68 : 0x94f6a8 (0x23d19000 0x99ee40 0x3e49ce0 0x471119c) 
    0x25623c98 : 0x38c3e5 (0x23d19000 0x3e27290 0x3e27290 0x0) 
    0x25623ce8 : 0x3b284a (0x23d19000 0x3e27290 0x3e27290 0x0) 
    0x25623d48 : 0x18d4d2 (0x23d19000 0x3e27290 0x0 0x0) 
    0x25623db8 : 0x12b4c3 (0x4711180 0x5153198 0x25623df8 0x11e042) 
    0x25623df8 : 0x124b17 (0x4711100 0x3df42e8 0x458bd68 0x0) 
    0x25623f08 : 0x195a42 (0x25623f44 0x0 0x0 0x0) 
    0x25623fc8 : 0x19b32e (0x4b040e0 0x0 0x10 0x0) No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xbfff7578
          Kernel loadable modules in backtrace (with dependencies):
             com.apple.GeForce(5.0.2)@0x93d000
                dependency: com.apple.iokit.IOPCIFamily(2.2)@0x5e5000
                dependency: com.apple.iokit.IOGraphicsFamily(1.4.7)@0x6ea000
                dependency: com.apple.iokit.IONDRVSupport(1.4.7)@0x705000
                dependency: com.apple.NVDAResman(5.0.2)@0x714000
    
    Kernel version:
    Darwin Kernel Version 8.10.1: Wed May 23 16:33:00 PDT 2007; root:xnu-792.22.5~1/RELEASE_I386
    
    Any help/suggestions would be appreciated. Many thanks in advance.
     
  2. Grafdude@gmail. macrumors newbie

    Joined:
    Jul 28, 2007
    #2
    Maybe a defective battery or the actual laptop, I would return the culprit for a replace, could likely be a defective magsafe power adapter.
     
  3. neuromage thread starter macrumors newbie

    Joined:
    Jul 30, 2007
    #3
    Fixed, I think

    Thanks for the reply, Grafdude.

    Anyway, I ran some tests, and here's what I found; The fan steadily ramps up to 6000rpm when the battery is being charged and either of the following happens:

    (1) Airport is switched on, and is being used to transfer data. When airport is switched off, and I use the ethernet connection instead, the fan speed drops back slowly to 2000rpm

    (2) Firefox is in use. Even with the Ethernet connection, using Firefox quickly causes the fans to ramp up to 6000rpm. I should mention that I recently updated firefox.

    Anyway, due to (1) I thought I should try this fix. And it worked surprisingly well! In fact, both problems (1) and (2) have gone away. Problem (2) especially is weird, since the fix is meant to downgrade airport drivers. Not sure how this affects firefox.

    Anyway, I thought I'd post this so other ppl having the same trouble know what to do. So I don't think it's a battery problem. Or so I hope. If the problem comes back, I'll post here again.
     
  4. neuromage thread starter macrumors newbie

    Joined:
    Jul 30, 2007
    #4
    Spoke too soon!

    No idea why, but the problem is back. So I was wrong, and this has nothing to do with airport. Also, made all the updates today, but same problem. Apparently, I'm not alone

    Anyone else with the same issue?
     
  5. vicious7 macrumors 6502a

    vicious7

    Joined:
    Jul 16, 2007
    Location:
    Jacked into the net...
    #5
    When I'm charging my battery, the memory control temp rises (60C-61C) and the fans shoot up to ~4500-4750 rpm. It's noticeable, but not as high as the 6000 rpm that others are reporting. After 25% charge, the fans drop down to ~4000 rpm with the memory control temp stable at 60C. All this when I'm using Safari.

    When I use Firefox, the memory control temp is 58C because the fans shoot up to ~5200 rpm and then after a few minutes, the fan control temp is back up to 60C and the fans drop down to 4100 rpm. I am confused...
     

Share This Page