mbp problem

Discussion in 'MacBook Pro' started by Kalashnikov, May 18, 2008.

  1. Kalashnikov macrumors member

    Joined:
    Feb 29, 2008
    #1
    Hello everyone. I have my mbp for 2 months now and i have a problem with it. When i turn it on i connect to the internet through my belkin router. For some reason, safari wont open any websites anymore and if it does manage it takes 10 minutes to open. Aol instant messanger turns on no problem same goes for limewire. But my safari will not open anything. I restarted my router but problem is still there. I tried my dell desktop and my other toshiba laptop they work as well. I ran diagnostics but it said that the computer is running fine. Can someone help me out? thanks
     
  2. wgilles macrumors 6502

    wgilles

    Joined:
    Feb 21, 2008
    #2
    Sounds like your airport card is crap. I'd take it to Apple and see if they can diagnose, do it soon before the 90 days is up unless you have AppleCare!
     
  3. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #3
    Are you using ethernet or wireless to connect to the belkin router? Are you using DHCP or a static IP address on your Mac?
     

Share This Page