MBP random wake from display sleep

Discussion in 'MacBook Pro' started by kaysirtap, Mar 30, 2011.

  1. kaysirtap, Mar 30, 2011
    Last edited: Apr 3, 2011

    kaysirtap macrumors newbie

    Mar 28, 2011
    I've seen many discussions about random wakes from sleep, but none of the situations seem to exactly match my own, so I thought I'd start a new thread.

    I'm running a late 2009 15" 2.8GHz MBP C2D with 10.6.7 and 4GB of RAM. I have the computer plugged in most of the time, and I've set the computer to never sleep while on AC power. The reason is because I use Internet Sharing to create a wireless network in my apartment. I use a hot corner to put the display to sleep whenever I'm not physically at the machine. I generally only keep the Finder and Mail running while the display is asleep. Little Snitch is also running in the background. In my Energy Saver preferences, I have unchecked the box that says "Wake for network access". There are no bluetooth devices connected to the computer.

    To my dismay, the computer's display occasionally turns on without any physical interaction with the computer. The wakes are not the result of any incoming email, and no Little Snitch alerts are on the screen. Little Snitch also does not seem to have automatically approved or denied any connections. I have not tested to see if the display later goes back to sleep according to the Energy Saver preferences. I also do not know if the computer would wake up from system sleep, as some other users have reported.

    How can I determine what is waking the display? I'm not really sure how to make use of the Console application, but I have a feeling someone's going to suggest looking at it.

    Any advice or information would be greatly appreciated. Thanks!

    UPDATE: The computer's display goes back to sleep according to the Energy Saver settings. Anybody know why it wakes up in the first place?
  2. kaysirtap thread starter macrumors newbie

    Mar 28, 2011
    ANOTHER UPDATE: The computer exhibits the same issue without Mail running, and with Internet Sharing turned off.

Share This Page