MBP randomly wakes from sleep

Discussion in 'MacBook Pro' started by nGoldenm, Sep 24, 2008.

  1. nGoldenm macrumors newbie

    Joined:
    Jun 19, 2007
    #1
    Hi guys,

    I'm having an ongoing problem with my MBP. I think that I finally have it narrowed down but have no idea how to fix it. I have tried searching, but could not find any information that was similar to mine.

    I've disabled the safe sleep function via Terminal. I have also disabled the allow bluetooth devices to awaken the computer. It does not have anything plugged into its USB ports. The only thing connected to the computer is the power cable. Sometimes that is not even connected.

    Here's an example:
    I'll be using my computer, and decide to shut the lid and put it to sleep. I close the lid. The sleep light comes on but does not pulsate immediately. The apple logo stays lit. After about 10-15 seconds, the apple logo goes off, and the sleep light begins to pulsate. As the sleep light nears its dimmest point, the computer wakes from sleep (about 2 seconds after the light has begun pulsating). If I open the lid at this point, the computer stays awake, but the brightness is turned all the way up and the brightness keys do not work. It just pops up the brightness adjust image on the screen, shows it increasing by one bar (starts at 0 bars), and then immediately returns back to zero. The only cure for this is to shut the lid again or restart the computer. If I shut the lid again, it goes through the same process as before except this time when it wakes from sleep, everything is normal. All of this occurs whether the computer is plugged into the power supply or not. Eventually it will stay asleep for longer periods of time if you let it go through this process with the lid remaining closed quite a few times. However, it will, at some point after a few hours, reawaken and go through the whole process again.

    Now, consider a different time. I shut the lid. The sleep light comes on, but the Apple logo stays lit. After 1-2 seconds, the apple logo disappears, and after 4 seconds max, the sleep light begins to pulsate. It then proceeds to sleep like normal. No reawakening problems. Just the good ole sleep that my old iBook performed thousands of times without fail.

    Now, I've noticed that if I manually turn off Airport, the problem disappears. I am not entirely certain that is what is causing it, but it is quite a coincidence.

    It is quite annoying to shut my computer while I'm at school, and, thinking it's asleep, stash it away in my bag only to find that it has been awakening constantly and draining the battery significantly with the display turned all the way up.

    Does anyone know of a fix for this? Or anything that I can try for that matter?

    Thanks.
     
  2. techound1 macrumors 68000

    techound1

    Joined:
    Mar 3, 2006
    #2
    If you bump a sleeping Mac portable you can wake it up. I assume it's reading a trackpad input as part of the bump, bringing it out of sleep.

    Alternatively, try resetting the SMC: http://support.apple.com/kb/HT1411?viewlocale=en_US and see if that helps.
     
  3. nGoldenm thread starter macrumors newbie

    Joined:
    Jun 19, 2007
    #3
    I tried resetting the SMC according to that article, but I still have the problem. I do not think that it is the bumping thing. It does it even though the Mac is sitting on a stable, level surface. I can also turn the Airport off manually, shut the lid, and bump the thing to my heart's content, and it will not awaken.

    The only constant in this equation seems to be the Airport. Is there anything that can be done to update the Airport or something like that?
     
  4. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
    #4
    I have a similar problem, but it only happens when I have a specific network setting, which is to share my internet connection. So what I've done is I've created several locations that I use depending on where I am (just go into the Network prefpane to manage your locations), and then before putting the computer to sleep I go into the Apple menu > Locations > "Everything Off".

    My "Everything Off" location has all network services disabled, including taking away power from the wireless card and bluetooth (it's great for saving battery life!). It always sleeps when I use this mode.

    Also, the reason why your laptop takes 10-15 seconds to go to sleep is because you're using the default sleep settings called "safe sleep". This writes the contents of all of your memory to the disk before sleeping so that in the event of a complete power failure (battery included), you can still recover. This rarely happens with a laptop that has a good battery.

    To disable safe sleep go into the Terminal and do this:

    Code:
    sudo pmset -a hibernatemode 0
    sudo rm /var/vm/sleepimage
    To re-enable it change the 0 to a 3 (and don't include the last line).

    Hope this helps!
     
  5. nGoldenm thread starter macrumors newbie

    Joined:
    Jun 19, 2007
    #5
    Thanks for the reply.

    Safe sleep is turned off on my computer. Has been for some time. The 10-15 second delay only happens if it is going to reawaken immediately. If it is not going to reawaken, it only takes 4 seconds max.

    The "Everything Off" setting is basically the same type of thing that I do when I turn my Airport connection to off. It sleeps every time as long as I turn it off.

    So what I'm wondering is if there is an update/fix for the Airport so that I don't have to do this work around to get my MBP to function as it should in the first place.
     
  6. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
    #6
    Ah gotcha, my apologies, I admit that I skimmed part of your post and didn't notice that, and now I sound like a dumbass because of it. That'll teach me. :eek:

    Then I have the same question as you do, and as far as I know there is no such fix yet. You can always report your problem to apple! If they get enough complaints maybe they'll finally do something about it.
     
  7. nGoldenm thread starter macrumors newbie

    Joined:
    Jun 19, 2007
    #7
    Don't sweat it.

    It very well could be that turning off the Airport also "disengages" the true problem. I don't know. All I know is that it is quite a coincidence that my computer sleeps every time without fail if the Airport is turned off. Hopefully they'll come out with a fix so I don't have to keep working around this oversight on their part.

    If anyone knows something that we don't, please enlighten us.
     
  8. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
    #8
    I suspect the same thing, as it does seem to go to sleep with the Airport on in certain situations, but I haven't worked hard enough at isolating what the difference is to figure it out. (I remember a while ago looking at the Console to see if there was any difference but don't remember seeing any).

    Indeed! :cool:
     
  9. nGoldenm thread starter macrumors newbie

    Joined:
    Jun 19, 2007
    #9
    Mine will sleep in certain situations also with the AirPort turned on. Another thing that I noticed is that when it reawakens on its own I immediately open the lid and it is connected to my wireless network. If it sleeps normally, it takes it a few seconds to reacquire a wireless connection. It almost seems like the AirPort is failing to disengage itself when going into sleep mode. Then when it goes into sleep, the Airport awakens the computer to reestablish the network connection. This is all just speculation on my part though, of course.
     
  10. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
    #10
    Interesting. I don't have the time right now to look into it too much, but if there was a way to find out when the computer is going to sleep, and when it's woken up, then it would be relatively easy to write an application that turns the Airport off and on for you on those events. You'd just launch it on login and it would run in the background.
     
  11. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
  12. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
    #12
    That was just too easy to pass up. Here's a proof-of-concept application that I'll release sometime soon as freeware:

    http://www.taoeffect.com/Wireless_Sleeper.app.zip

    Just run it and try sleeping, let me know how it works for you! The final version won't appear in the dock.

    Edit: updated that link to version 0.1, it should only display the notice at startup only once on first run from now on
     
  13. Denarius macrumors 6502a

    Denarius

    Joined:
    Feb 5, 2008
    Location:
    Gironde, France
    #13
    I have no exerience of this issue, but wondered it this thought might be worthwhile for you?

    You seem to have isolated it to your Airport. Have you tried to put it to sleep with wireless enabled but out of range of a wireless network? May help to determine whether it's something funky in the hardware or something odd in the network configuration perhaps. Another scenario to explore might be wireless enabled, with networks in range but not connected. Just thought this might help determine whether the problem is with software configuration or hardware.
     
  14. nGoldenm thread starter macrumors newbie

    Joined:
    Jun 19, 2007
    #14

    It's a little early to say anything definitive, but it appears as though it could be a home run. In my early testing, I haven't had a single problem yet getting my computer to sleep. Kudos!

    I'll send you a PM in a minute to discuss it further. Thanks again!
     
  15. nGoldenm thread starter macrumors newbie

    Joined:
    Jun 19, 2007
    #15
    I do not have a place to test the "no networks in range" theory, but I did test the "networks in range but not connected" one. I get the same results as I have normally. It will not sleep. As soon as it awakens, however, it is already connected to my wireless network. I'll try the no networks thing as soon as I can find a place that does not have networks in range.

    Of course all of this was done without itistoday's nifty little application running.
     
  16. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
    #16
    Glad to hear it worked! (Check your PMs for the reply)
     
  17. holden15 macrumors member

    Joined:
    Sep 8, 2008
    Location:
    Austin, TX
    #17
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F137 Safari/525.20)

    I had that same problem, until I turned Bluetooth completly off. The only thing I had paired with it was my iPhone and my Mighty Mouse.
     
  18. nGoldenm thread starter macrumors newbie

    Joined:
    Jun 19, 2007
    #18
    I have bluetooth turned off completely as well, yet I still have the problem.
     
  19. itistoday macrumors newbie

    Joined:
    Sep 24, 2008

Share This Page