MBP refusing to turn on

Discussion in 'Mac Basics and Help' started by Trent0341, Feb 18, 2009.

  1. Trent0341 macrumors 6502

    Joined:
    Jun 3, 2007
    #1
    Hey all,
    Recently my MBP (15" Santa Rosa) froze up. After having to force it to turn off it now no longer turns on. It will make the start up sound but it is very muted. Anyone eles had this problem? Or a solution? Thanks
     
  2. majordude macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #2
    Try pushing and holding down the "On" button until it beeeeeeeeeeps. That's something like after 15 seconds of holding it down. Hopefully that's all you need.
     
  3. Trent0341 thread starter macrumors 6502

    Joined:
    Jun 3, 2007
  4. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #4
    Try resetting the PRAM

    Cmd option P R on boot.


    If nothing, reset the SMC:

    Disconnect the AC Adapter and remove the computer's battery.
    Press and hold the power button for 5 seconds and then release the button.
    Reconnect the battery and AC Adapter.
    Press the power button to restart the computer
     
  5. Trent0341 thread starter macrumors 6502

    Joined:
    Jun 3, 2007
    #5
    Tried resetting the PRAM and the SMC again, with no luck. I have an appointment at the Apple Store on saturday. Not having my Mac sucks!:(
     
  6. majordude macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #6
    Wow, that DOES blow. I'd panic if mine did that. I'm lost without my MBP and iPhone.
     
  7. Trent0341 thread starter macrumors 6502

    Joined:
    Jun 3, 2007
    #7
    Can't say I'm to happy right now. Hopefully this is taken care of tommorow. At least I still have my iPhone.
     
  8. majordude macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #8
    What's the status?
     
  9. Maldini macrumors regular

    Maldini

    Joined:
    Nov 21, 2007
    Location:
    Riyadh
    #9
    My MBP SR did the same a month ago... I went to the Apple store and they told me that my logic board was damaged and a new one will cost me 850 $ :eek:.... worst days of my life....

    I hope you dont have the same problem
     

Share This Page