MBP saying it cannot find macOS files. Stuck on start.

Discussion in 'macOS' started by nia820, Apr 21, 2018.

  1. nia820 macrumors 68020

    nia820

    Joined:
    Jun 27, 2011
    #1
    [​IMG]

    This morning my 2017 mbp updated went to restart. Then I got this message on the screen. I tried restarting it many times but it's still stuck.

    Any ideas on how to fix this other than formatting it?

    Also there are no apple stores where I live so it's not an option.
     
  2. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Hold CMD + R on startup, select Reinstall macOS. This won't wipe your data, just reinstall the core OS. Hopefully this should fix the problem.
     
  3. nia820 thread starter macrumors 68020

    nia820

    Joined:
    Jun 27, 2011
    #3
    Thanks! It worked.
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    OP:
    Do you have the App Store setting (system preferences) set so that updates are automatically downloaded and installed?

    If so, I would UNcheck the "automatic install" option.
    I don't mind being notified that updates are available, but...
    I want to install them "manually" -- so I know what's going on.
    I don't like updates "installed behind my back".
    That can produce unexpected results -- like those you had above.
     

Share This Page