MBP Screen Stays Off When Booting

Discussion in 'MacBook Pro' started by SimonBook, Nov 14, 2009.

  1. SimonBook macrumors member

    SimonBook

    Joined:
    Aug 9, 2007
    Location:
    Vienna, Austria
    #1
    Hi,

    When I turn on my two year-old 15" MBP it boots, but the screen seems to stay off. When I increase the volume I can hear the standard sound, although sometimes slightly delayed. I've tried turning the brightness up and moving the mouse out of the bottom left corner, which puts my display to sleep, but neither worked. I've rebooted countless times.

    I've been having problems with my battery. According to Snow Leopard I should "replace now". Could it be related to this?

    Has anyone experienced the same problem? Any ideas? Any help is appreciated.

    Thanks in advance,
    Simon
     
  2. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #2
    Possibly your GPU failed. The 8600M GT's are failing at an alarming rate, something NVIDIA came out and acknowledged last year. Apple is giving a three year warranty on the GPU.

    If you've got an Apple Store nearby, take it in. It sounds very like the GPU failed - screen being blank yet the computer booting.
     
  3. SimonBook thread starter macrumors member

    SimonBook

    Joined:
    Aug 9, 2007
    Location:
    Vienna, Austria
    #3
    I let it rest over night because I thought something might have overheated, but the screen still didn't work this morning. I will take it to the store first thing on Monday.

    Thanks a bunch.
     

Share This Page