Mbp screen won't come on- nvidia issue?

Discussion in 'MacBook Pro' started by docal97, Jun 23, 2009.

  1. docal97 macrumors 6502a

    docal97

    Joined:
    Jun 28, 2006
    Location:
    Southampton
    #1
    So here is the situation:

    I have a 2.4 ghz mbp. Over the past week, ihave noticed that often when I boot, the screen is essentially dead. I get the iniatial boot up chime, but the screen does not come on at all. Every once in awhile, it will come on with booting, but usually will not. I have never had this issue before.

    I have the latest version of the OS, did all the various resets per the apple support website and nothing has worked. I can connect the mbp to another mb va FireWire and see and access my hardrive.

    Dies this sound like the nvidia video issue? I curious of others experiences with similar issues. I have an evaluate schedUled for tomorrow at a local apple store.
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    I've noticed from time to time where the display will taking a long time to turn on.

    Check your brightness settings as well.
     
  3. sos85 macrumors member

    Joined:
    Feb 20, 2009
    Location:
    nw2 7jp Londo
    #3
  4. docal97 thread starter macrumors 6502a

    docal97

    Joined:
    Jun 28, 2006
    Location:
    Southampton
    #4
    Are you referring to a specific weblink? I have searched that site and there is nothing that I can find there in regards to my issue.
     
  5. docal97 thread starter macrumors 6502a

    docal97

    Joined:
    Jun 28, 2006
    Location:
    Southampton
    #5
    So I took the mbp in today and met with the Genius. He took it into the back for about 5 minutes and then came out and said that I had a bad video card, and that it was related to the Nvidia problem that is documented. They kept the mbp and will be replacing the logic board. It should take approximately 2-4 days.
     

Share This Page