MBP Sleep/wakeup Stuck Key

Discussion in 'MacBook Pro' started by falterego, Feb 14, 2011.

  1. falterego macrumors 6502

    falterego

    Joined:
    Dec 28, 2008
    Location:
    Southern California
    #1
    It seems that almost every time I sleep and then wake up my 2010 MBP, the system thinks I am holding the command key down. I would estimate this happens 90% of the time. Here are the things I've tried/confirmed about the problem

    • It does not matter if I am on A/C power or battery.
    • It does not matter if I have any applications open when the computer sleeps.
    • It does not matter if I have a bluetooth device (Magic Mouse or headset) connected or not.
    • Restarting the computer fixes the problem instantly.
    • Restting PRAM (Command+Option+P+R) does not have any effect.
    • Disabling the sleep cache file on the system does not have any effect.
    • Pressing the Command key while this is happening does not make any difference.
    • When this is happening, if I double tap the trackpad or do a Control+Click I get the same effect as a single click. I effectively have no Control+Click ability when this happens.

    Has anyone else had this issue? It's becoming quite annoying to have to restart my computer every time I sleep it or it goes to sleep. It is also very difficult to perform any tasks when the computer thinks the Command button is being held down.
     
  2. Fubar1977 macrumors 6502a

    Fubar1977

    Joined:
    Jul 30, 2010
    Location:
    North Yorkshire, UK
    #2
    It does sound like a faulty key so your only option may be to have it repaired, it doesn`t really sound like a software issue, assuming the MBP behaves as tho the key is depressed constantly (after booting).
     
  3. falterego thread starter macrumors 6502

    falterego

    Joined:
    Dec 28, 2008
    Location:
    Southern California
    #3
    Rebooting does resolve the problem, so it seems entirely software related to me. I've even gone as far as turning on the computer and using it without ever touching the Command key, sleeping the system and waking it back up and the problem begins. It looks like I'm going to have to make a trip to the store to see if they have any suggestions. All the other search results that I've found on the web are from around 8-9 years ago, so it does not seem like a big issue for anyone.
     

Share This Page