MBP slow bootup & running VERY slow

Discussion in 'MacBook Pro' started by markw10, Jan 20, 2010.

  1. markw10 macrumors 6502

    Joined:
    Sep 4, 2006
    #1
    I have a 2007 Santa Rose MBP and it has started to run very slow during the bootup and actual use of it. Here is how the bootup goes:

    I turn it on and get the bong sound and a full white screen. In about 10 seconds I get the Apple log and in about another 10 seconds the circle that rotates as it boots up.

    Then at about 2 minutes it changes color to a light blue color with the pointer on the screen. Then in about another 10 seconds changes to a darker shade of blue. At a total of 3 mins and 40 secs I then get the desktop with the space type background and in a couple more seconds the Mac OS X login screen. It takes around a minute until I am able to type anything. For awhile before that time I can type I get the beachball.

    Here are the details of what I recently did:
    I had a 250GB hard drive in my MBP running the newest version of Leopard. I was down to around 50GB free so I purchased a 640GB hard drive. I also was due to upgrade to Snow Leopard. I had an external USB enclosure that I could temporarily use. What I did is put the 640GB hard drive in that external enclosure and formatted it with the GUID partition table. I then used SuperDuper to mirror my internal hard drive to the external hard drive. I have a lot of programs installed and a lot data on my hard drive so didn't want to lose any of this.

    Once the mirroring of my internal hard drive was completed to my external 640GB hard drive I then booted from that drive (using it externally and selecting option at bootup). Things seemed to run fine with no issues.
    I then after booting up from this external hard drive did a Snow Leopard upgrade to this external hard drive. Once again this external hard drive appeared to run perfectly normal.

    After things seemed to be okay I then opened up the MBP and swapped hard drives so the 640GB drive was my new internal HD. I then booted and once again I used it some and things appeared to work normally.

    After this later in the evening I installed two programs, Final Cut Studio 3 and Logic Studio 9. As far as I can remember my computer was acting a little odd and after a reboot that is when all the above issues started.

    As far as I can tell this never started until those two installs. Is it a chance I didn't try it out enough but I remember even with the HD being external USB my system appeared to run faster than ever. I even think the program didn't start with Final Cut Studio but started with Logic Studio 9

    Any idea of what caused this? Even after my computer running it's VERY slow to the point of being almost unusable. For example if I open Word it takes 3 minutes or so to open. Almost any action causes the beachball to appear.

    After looking at the Apple site I did both a PRAM erase (using Command Option P and N) and also a SMC reset by removing the battery and power cord and pressing the power button for over 5 seconds and neither fixed it.

    I opened up Disk Utility and did a Verify Permission and got the following information:

    Permissions differ on "usr/share/derby", should be drwxr-xr-x, they are lrwxr-xr-x.
    Warning: SUID file "System/Library/CoreS...as been modified and will not be repaired.

    Since it said it didn't repair it I did a Repair Disk Permissions but that didn't seem to fix it.

    Could these two issues be the problem and if so how can I fix them?
    Thank you for your help.
     
  2. ViciousShadow21 macrumors 68020

    ViciousShadow21

    Joined:
    Mar 11, 2009
    Location:
    To your left or right
    #2
    real quick try resetting the PRAM. it sounds like it could be a permission or log problem but you never know. the installing of those applications could be throwing something off.

    you said that you ran disk utility to repair permissions but it didnt work. i find that Onyx (make sure you dl the one for the OS you are currently using) does a better job at assessing and repairing problems.

    if that doesnt do anything for you try running a Hardware Test. it could be that those applications are corrupting the HDD even tho they are apple applications.
     
  3. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #3
    In my quick read of what you posted, it's not clear what disk you had booted from when you ran Disk Utility.

    DU won't let you repair the boot disk. Try booting from your SL CD and running DU from there.
     
  4. markw10 thread starter macrumors 6502

    Joined:
    Sep 4, 2006
    #4
    I tried booting from my original Leopard disk and and then running DU on the internal Snow Leopard 640GB drive. Unfortunately it still said it won't repair those errors. I did some research online though and it appears that those errors with the permissions can be ignored and should not cause any problems.
     

Share This Page