MBP SSD Swap: Still waiting for root device

Discussion in 'MacBook Pro' started by xtimmyx, Nov 13, 2010.

  1. xtimmyx macrumors newbie

    Joined:
    Oct 5, 2006
    #1
    I've just installed a 120GB OCZ Vertex 2 SSD into my 17" 2.5GHz Macbook Pro 2008.

    However, when trying to install Snow Leopard onto it, it stops and gives me "Still waiting for root device" error over and over before the installation starts.

    The SSD itself works just fine as far as I can tell (I can read/write/format/partion it when booting from my previous drive via USB). But it can't seem to be identified or whatever during the OS X installation.

    Any ideas?
     
  2. cili0 macrumors member

    Joined:
    Jan 19, 2010
    Location:
    Italy
    #2
    in the hackintosh world 'still waiting for root device' means that the operating system doesn't recognise the chipset on the motherboard and so it can't find the installation media or the hard disk. So it's quite strange you experienced that error given the fact that your computer it's a real mac.
     
  3. SomeOtherGuy macrumors newbie

    Joined:
    Mar 14, 2008
    #3
    It may be obvious, but have you tried formatting the drive before you start the installation?
     
  4. xtimmyx thread starter macrumors newbie

    Joined:
    Oct 5, 2006
    #4
    Problem solved:
    I tried with a 10.5 disc I had lying around and that for some reason worked. So something must have been wrong with my SL disc.

    Instead I made a bootable USB drive with SL and that worked just fine. Quick install and so far it's been running just perfect on my computer.
     

Share This Page