MBP Storage Discrepancy

AppleDApp

macrumors 68020
Original poster
Jun 21, 2011
2,410
42
Hey all!

I have a MBP I am trying to clean some of the things on the drive. I am getting different information in different places I check.

AFAIK the most reliable reading comes from the get info window on Macintosh HD. The about this Mac window says I have 200GB of other data.

Any idea how I can get these three tools to display the same amount of available storage? I have tried multiple scans with DaisyDisk and tried a reboot nothing seems to sync them up.
Screen Shot 2015-10-25 at 2.41.02 PM.png
Screen Shot 2015-10-25 at 2.42.19 PM.png
Screen Shot 2015-10-25 at 2.42.32 PM.png
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,323
10,068
California
First... just ignore that Other readout. It is completely messed up and inaccurate in both Yosemite and El Capitan.

But the reason your totals are showing different amounts is because of Time Machine's local snapshots. You are using 64GB for these local snapshots. That space IS included in the Disk Utility total and is not included in the Finder total, hence the difference.

You are fine. :)
 

AppleDApp

macrumors 68020
Original poster
Jun 21, 2011
2,410
42
great thanks how I can I reduce or eliminate the time machine local snapshots? I backup everyday it should be that much for local snapshots?
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,323
10,068
California
great thanks how I can I reduce or eliminate the time machine local snapshots? I backup everyday it should be that much for local snapshots?
Even if you backup, it still uses that space. You have some options.

1. Ignore it. When the disk approaches 80% full the OS will begin to shrink down that space.
2. Turn Time Machine off then back on and the space will be zeroed out. But it will begin to grow again.
3. Run the command below in Terminal to disable the feature.

Code:
sudo tmutil disablelocal
 

AppleDApp

macrumors 68020
Original poster
Jun 21, 2011
2,410
42
Hey Weaselboy thank you for the command this has very helpful on multiple machines this week.

Code:
sudo tmutil enablelocal
 
  • Like
Reactions: Weaselboy
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.