MBP stuck at startup screen - tried everything.

Discussion in 'OS X Mountain Lion (10.8)' started by animusheart, Nov 16, 2012.

  1. animusheart macrumors newbie

    Joined:
    Feb 18, 2011
    #1
    It was working last night, but shut down abruptly because it ran out of battery. Tried starting it up this morning but it won't get past the startup screen. Tried all the suggestions in the forum, nothing worked. When I entered cmd +s, I get a disk02s2: I/0 error and a whole string of "Invalid node structure" and "invalid record count"

    Please help! I hope it's not a crash.
     
  2. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #2
    Those errors mean the directory is messed up, and Disk Utility may or may not be able to fix it. 1. Try to boot up from the recovery HD partition if you are running Lion/Mountain Lion and run Disk Utility to repair the damaged disk. 2. If that doesn't work, boot from your external backup disk (you do have one, don't you?) and run Disk Warrior to replace the messed up directory. IF DW cannot fix it, you might as well give up and buy a new HD or SSD, reinstall the OS and migrate your backed-up data.
    3. Use the Edit post function, advanced option and edit the subject line to erase the "tried everything" :D 'cause you still haven't done that yet. ;)
     

Share This Page