MBP suddenly running very slowly...

Discussion in 'OS X Mavericks (10.9)' started by aarwynn, Mar 31, 2014.

  1. aarwynn macrumors newbie

    Mar 31, 2014
    Yesterday, my Mac started running very slowly. The OS as a whole is very slow, rather than just one specific program. It has never behaved like this before, and I cannot recall any specific changes that would make it behave this way. My Time Machine back-up has also been "Preparing Backup..." for a few hours now. Not sure if this is related, but usually it does not take this long to prepare.

    I have tried SMC reset and repairing my disk in recovery mode, but these have not helped. Any further suggestions would be greatly appreciated.

    Very many thanks,


    MacBook Pro, OS X Mavericks (10.9.2), 2.9 GHz i7, 8 GB memory.
  2. macgeek88 Suspended

    Jan 16, 2013
    I'd repair permissions (you didn't say if you repaired the HD and the permissions or just the HD, but permissions would help) and throw in a PRAM reset as well.

    Also, you could try running something like OnyX and see if cleaning your cache helps any.
  3. \-V-/ Suspended


    May 3, 2012
  4. aicul macrumors 6502a

    Jun 20, 2007
    no cars, only boats
    I've had this, and maybe this is your case as well. Its about the distnoted process. There are quite a few web pages on this. Try google.

    I'm not suggesting any solution because I banged on the mac again and again with multiple tries until "something" worked. So I am at a loss to telling you how I solved the matter.
  5. aarwynn thread starter macrumors newbie

    Mar 31, 2014
    The End Result

    Hi everyone -- thank you for your replies. I was MIA in this thread because as it turned out, my hard drive was completely dead (thankfully, I have a Time Machine backup).

    Payed a visit to the Apple Store yesterday and they replaced it that very same day! $200 after tax. Could have been worse.

Share This Page