MBP takes ages to connect to internet in one room only

Discussion in 'MacBook Pro' started by Dtbain, Sep 3, 2014.

  1. Dtbain macrumors newbie

    Joined:
    Jul 12, 2010
    #1
    Hi all

    My brand new MBP is taking ages to connect to the internet when in the living room but not in the study (where the router is).

    Two things are odd about this:

    1. It IS connected to wifi, i.e. all the bars of the wifi symbol are black, indicating a strong signal. The problem is that, using Chrome (and Safari), when I enter a web address, it just hangs for ages then eventually, sometimes after 5-10 minutes, it connects, and thereafter things tend to be fine.

    2. My very old Dell laptop connects MUCH more quickly; I simply don't have the same problem with it. It seems to not only find the wifi signal but to access websites more or less immediately.

    On the one hand, given this only happens when in the living room, some distance from the router, I would think the problem is simply that the wifi signal is too weak. In that case, I'd be happy to buy a new router or signal booster. On the other hand, both 1 and 2 call this diagnosis into question. So I'm confused!

    Any advice or help would be MUCH appreciated.

    Thanks

    d
     
  2. Nr123*123 macrumors 6502

    Joined:
    Jul 1, 2014
    #2
    I have found the same with my Mid 2014 rmbp. At first I thought it was the router, but as you mentioned, other devices connect fine. Mine also randomly goes off or fails to load a page. I have to turn the wifi on and off to work.

    I'm certain it's software related, as the all of the rmbps I've had did this.
     
  3. Dtbain thread starter macrumors newbie

    Joined:
    Jul 12, 2010
    #3
    Many thanks. How annoying that the MBP should perform worse than an 8 year old dell. I'm considering an Apple airport; do you think that might help? D
     
  4. TheBirdMan81 macrumors newbie

    Joined:
    Sep 3, 2014
    #4
    I'm having the exact same issue with my 2014 MacBook Pro 13' retina. I don't think it's the router either, everything is working fine in the same location except the laptop. I have an Apple Time Capsule with 802.11ac. Not sure if you guys are using the public beta of Yosemite but I am. Not sure if that might be the problem. But I also have full signal and am only about 60 feet away from the router but can't get on. Hope this helps.
     
  5. Nr123*123 macrumors 6502

    Joined:
    Jul 1, 2014
    #5
    No, I am on Mavericks. I don't think an airport express will help, as it's not the router. If you google retina MacBook Pro wifi it seems to be a common problem.
     
  6. Dtbain thread starter macrumors newbie

    Joined:
    Jul 12, 2010
    #6
    I'm also on Mavericks. It's the latest MBP, bought in August.

    When you say you turn the wifi on and off again, Nr321, do you mean the router, or do you mean no the MBP, in System Preferences?

    The reason I thought a better router might help is that, even though my other (much cheaper and older!) laptop is coping much better in the living room, even my MBP copes fine in the room the router's in. So the problem seems to be room-sensitive. Is that the same for you?

    I'm new to mac and partly forked out eye-watering sums to avoid such problems? Do you know have to ensure Mac know about this and are doing something?

    Sorry for all the questions, and thanks for the help.

    d
     
  7. Nr123*123 macrumors 6502

    Joined:
    Jul 1, 2014
    #7
    Happy to answer questions mate, don't worry.

    Mine is also the latest one (Mid 2014 15" 2.5ghz etc) but I have had two late 2013 15" and they both did the same thing. This, along with some posters on here suggesting interference between USB3 and wifi (google that), has led me to believe it is a software issue.

    Indeed, mine is better if I am directly in the room with the router and drops off if I am not. The same happens in uni, I will close the lid and when I reopen after a short while it often struggles to reconnect to the wifi. What I do is turn the wifi on my Mac on and off.

    I hope Yosemite will fix this, as it gets annoying having to connect on and off.
     

Share This Page