MBP Unibody 2.53 Disk Issues? Help!

Discussion in 'MacBook Pro' started by jaynone, Apr 24, 2012.

  1. jaynone macrumors member

    Joined:
    Jan 2, 2012
    #1
    Hi Everyone.

    So, here it goes. I can't figure out how to fix my system.

    I'm using my system this afternoon, everything is good, the only thing out of the ordinary was that I plugged in my USB data stick that I haven't used since last September. I installed the drivers for it, and everything seemed to be working fine. I closed my system and left for a few minutes. I came back and opened it and it wouldn't wake from sleep. It was ON, but not responding. I killed the system power by holding the power switch for 10 seconds and then rebooted. The system would then come on, ask me for the file vault password to unlock the disk, then hang at the apple logo.

    I tried to restart from the recovery partition. It has disappeared.

    I got my external hard drive with an older system clone and plugged it on. It boots off that fine and I started up disk utility, unlocked the boot partition, repaired permissions and decrypted the drive. Tried to reboot and nothing happened.

    The recovery partition is visible, but not bootable. Disk utility says it cannot mount the boot partition, but when I boot from my backup drive I can access the drive and the files on it, but since disk utility can't read the disk I can't repair it. I can't get to the recovery partition to access my time capsule backups either.

    I'm at a loss for what to do exactly? Any ideas?

    I'm going to try a SMC reset and go from there.

    Thanks
     
  2. jaynone thread starter macrumors member

    Joined:
    Jan 2, 2012
    #2
    So, Disk utility can't change the partition map on this drive. It says to use the command line diskutil to edit the disk because it contains encrypted partitions.
     

Share This Page