MBP Unibody Trackpad Problem?

Discussion in 'MacBook Pro' started by dirkph, Aug 17, 2010.

  1. dirkph macrumors member

    Joined:
    Nov 7, 2008
    #1
    I'm wondering if anyone else in this forum is having the same glitch I'm having on my late 2008 MBP.

    Every now and then, my trackpad will glitch out and stay "clicked." As in, my fingers won't even be pressing down on the track pad but when I scroll around, the mouse acts as if I've clicked and stayed clicked the whole time. I run into many problems such as me dragging stuff around my desktop that I don't even want to drag.

    No, this isn't a hardware problem... the trackpad doesn't physically stay clicked, it's clearly a software-related issue.

    I have BetterTouchTool installed, but I've had it installed for awhile now and this new problem is a fairly new phenomena. It's not a massively huge deal, but it's certainly quite annoying.
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
  3. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #3
    Man, there are several recent threads on this right now. All we can do is wait for Apple to send out a trackpad update.
     
  4. cosmokanga2 macrumors 6502a

    cosmokanga2

    Joined:
    Jan 7, 2008
    Location:
    Canada, where we live in igloos.
    #4
    I just had this problem appear in the last 3 day after getting my logic board replaced twice and my display replaced once. It only started after getting the repairs and the MBP hasn't been updated/alter before or since. Is it maybe hardware related somehow?

    EDIT: Just booked a genius appointment after it happened 3 times in 10 minutes. Reset the PRAM and SMC after the second time but it happened again. Really frustrating after I have lost a combined 24 hours of work after repairs and problems.

    VV mgartner0622: It has happened to me both with and without my USB mouse connected. Bluetooth has always been off for me.
     
  5. mgartner0622 macrumors 65816

    mgartner0622

    Joined:
    Jun 6, 2010
    Location:
    Colorado, USA
    #5
    Does anyone by chance have an external mouse connected at the same time they are using the trackpad?

    The same issue happened to my '09 13" and once I turned off bluetooth (Magic Mouse Connected) it went away. I JUST UPGRADED TO 10.6.4 TODAY. I was waiting for a graphics fix for steam games =). It never happened before on 6.3

    I'm hoping mine stays fixed now. :cool:
     
  6. 08AvengerRT macrumors newbie

    Joined:
    Aug 18, 2010
    #6
    I've been having this problem too. I read in another thread that it's a hardware problem. I really hope that's not true. Also I don't have an external mouse connected, or bluetooth on. Hope this can be fixed. It's an 09 one, low end 13."
     

Share This Page